Bug 211051 - Change luxi fonts with generic ones in release notes and splash page
Change luxi fonts with generic ones in release notes and splash page
Status: CLOSED NEXTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
http://fedora.redhat.com/css/content.css
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-16 18:52 EDT by Dimitris Glezos
Modified: 2007-04-18 13:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-16 20:06:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Shot of default FC6 desktop's browser splash page (4.86 KB, image/png)
2006-10-16 18:52 EDT, Dimitris Glezos
no flags Details
Let's try a snapshot of a sane size this time... (141.36 KB, image/png)
2006-10-16 18:58 EDT, Dimitris Glezos
no flags Details

  None (edit)
Description Dimitris Glezos 2006-10-16 18:52:05 EDT
## Description of problem:

In the release notes' CSS and browser splash page we use luxi-sans for headings
and other stuff, which is not displayed OK for some languages, such as greek
(see attached screenshot)

We should replace these with generic classes, like sans, serif, or even Dejavu ones.
Comment 1 Dimitris Glezos 2006-10-16 18:52:06 EDT
Created attachment 138637 [details]
Shot of default FC6 desktop's browser splash page
Comment 2 Dimitris Glezos 2006-10-16 18:58:03 EDT
Created attachment 138638 [details]
Let's try a snapshot of a sane size this time...
Comment 3 Patrick Barnes 2006-10-16 19:07:54 EDT
Standing recommendations are to list font family first and generic classes as 
fallbacks.  I certainly don't see anything wrong with something like:

font: "Dejavu Sans", sans-serif;

Though we could specify other alternatives, too.

This also affects the fedora.redhat.com website and other derivatives.
Comment 4 Dimitris 2006-10-17 21:37:40 EDT
we should at least have the following:

font-family: sans-serif;

as specified by the W3C, the font-family should contain a generic family of
fonts, either on its own or after any specific fonts.

the above should use Dejavu in FC and Arial in Windows (arial is default for
sans-serif family of fonts).
Comment 5 Dimitris Glezos 2006-10-17 21:56:24 EDT
This issue is already fixed in Rawhide and because of the slip it will be
included in FC6 as well.

We have a similar fix scheduled for all fedora.redhat.com websites' CSS files
too (see bug #211059).

Note You need to log in before you can comment on or make changes to this bug.