Bug 211079 - Logrotate complains about taboo extensions
Logrotate complains about taboo extensions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: logrotate (Show other bugs)
4.4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Tomas Smetana
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 02:24 EDT by Mathieu Larchet
Modified: 2015-01-07 19:14 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0703
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:52:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Larchet 2006-10-17 02:24:42 EDT
Description of problem:

Logrotate complains about files ending with ~ character even if it's present in
taboo extensions.

How reproducible:

Steps to Reproduce:
1. Edit a file in /etc/logrotate.d
2. Make some changes
3. Save the file (backup file is created with ~ extension)
4. Launch logrotate
  
Actual results:

Logrotate makes an error :
error: Ignoring xxxxx~, because of ~ ending
If logrotate is executed by crontab, an email is sent

Expected results:

If ~ is present in taboo extensions (which is true by default) no error should
be reported at all
Comment 2 RHEL Product and Program Management 2007-11-28 23:23:55 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-07-24 15:52:01 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0703.html

Note You need to log in before you can comment on or make changes to this bug.