Bug 211087 - Networking in 2.6.18-1.2200.fc5.i686 is effectively disabled [security_compute_av: unrecognized class 57]
Networking in 2.6.18-1.2200.fc5.i686 is effectively disabled [security_comput...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Paris
Brian Brock
:
: 211115 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 05:41 EDT by QingLong
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 00:51:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description QingLong 2006-10-17 05:41:24 EDT
Description of problem:
No real network action succeeds in 2.6.18-1.2200.fc5.i686 kernel,
the kernel prints `security_compute_av:  unrecognized class 57'
and the operation fails with `Operation not permitted'.
So I have to run the kernel with selinux=0 to get networking functionality.

Version-Release number of selected component (if applicable):
2.6.18-1.2200.fc5.i686


How reproducible:
100%

Steps to Reproduce:
1.Just load the kernel
  
Actual results:
Networking functionality is effectively disabled.

Expected results:
Networking should be available.


Additional info:
selinux related packages installed on the system:
libselinux-1.30.3-4.fc5
libselinux-devel-1.30.3-4.fc5
libselinux-python-1.30.3-4.fc5
libsepol-1.12.17-1.fc5
policycoreutils-1.30.10-2.fc5
selinux-doc-1.25.2-1
selinux-policy-2.3.7-2.fc5
selinux-policy-devel-2.3.7-2.fc5
selinux-policy-strict-2.3.7-2.fc5
Comment 1 jlbartos 2006-10-17 13:41:56 EDT
Exactly the same problems.
2.6.18-1.2200.fc5.i686
selinux enabled
sshd, named, ping, and other network functionality stops working.

It continues to work as a router, but it doesn't connect itself to the network.

Lots of
security_compute_av:  unrecognized class 57
during bootup and shutdown.

I did a /.autorelabel, thinking it was a labelling issue, but same problems.

Everything works again with previous kernel.

I think this is high priority problem.
Comment 2 jlbartos 2006-10-17 14:00:48 EDT
Could this be a initrd problem?
http://blogs.gnome.org/view/newren/2006/10/02/0
Comment 3 Dave Jones 2006-10-18 02:47:52 EDT
argh, this stuff should have been disabled.  I've fixed it in CVS. There'll be
an update real soon.  In the meantime, boot with selinux_compat_net=1
Comment 4 Dave Jones 2006-10-18 02:48:57 EDT
*** Bug 211115 has been marked as a duplicate of this bug. ***
Comment 5 Robert 'Bob' Jensen 2006-10-18 11:32:27 EDT
I also see the "security_compute_av:  unrecognized class 57" messages on boot up
of one of my machines however this system never finishes booting to see exactly
what is impacted. I tried booting with "selinux_compat_net=1" and SElinux set to
enforcing, no luck. The only way I can get the system to boot is to disable
selinux or boot to the older kernel.
Comment 6 Robert 'Bob' Jensen 2006-10-18 11:35:20 EDT
Oh I am sorry "selinux_compat_net=1" did work, sorry about adding a premature "Me2"
Comment 7 jlbartos 2006-10-18 18:53:48 EDT
selinux_compat_net=1 also works for me
Comment 8 Dave Jones 2006-11-12 00:51:26 EST
should be fixed in 2.6.18-1.2239.fc5 now in updates.

Note You need to log in before you can comment on or make changes to this bug.