Bug 211193 - Python error when specifying vnc port
Summary: Python error when specifying vnc port
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 211208
TreeView+ depends on / blocked
 
Reported: 2006-10-17 20:01 UTC by Ulrich Drepper
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 23:16:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix the cast to int (1.29 KB, patch)
2006-10-17 20:47 UTC, Daniel Berrange
no flags Details | Diff

Description Ulrich Drepper 2006-10-17 20:01:47 UTC
Description of problem:
When using virt-install and using a non-standard vnc port (2 == 5902 in my case)
the installation fails with an error in xend because of a type mismatch:

Traceback (most recent call last):
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
195, in creat
e
    vm.initDomain()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
1355, in init
Domain
    self.createDevices()
  File "/usr/lib64/python2.4/site-packages/xen/xend/XendDomainInfo.py", line
1518, in crea
teDevices
    self.image.createDeviceModel()
  File "/usr/lib64/python2.4/site-packages/xen/xend/image.py", line 249, in
createDeviceMo
del
    args += [ "--vncport", "%d" %(5900 + self.vncdisplay,) ]


self.vncdisply is a string.



Version-Release number of selected component (if applicable):
xen-3.0.2-44.x86_64

How reproducible:
always

Steps to Reproduce:
1.virt-install -d --p -n name -r 512 -f /dev/sda8 --vnc --vncport 5902 -l
nfs:host:/some/path
2.
3.
  
Actual results:

libvir: Xen Daemon error : POST operation failed: (xend.err "Error creating
domain: unsupported operand type(s) for +: 'int' and 'str'")

and the message above in /var/log/xend.log


Expected results:

no message

Additional info:

Comment 1 Daniel Berrange 2006-10-17 20:46:14 UTC
The string -> int conversion in image.py is only casting the default value to an
int, not a user supplied value.

Comment 2 Daniel Berrange 2006-10-17 20:47:30 UTC
Created attachment 138725 [details]
Fix the cast to int

Comment 3 Red Hat Bugzilla 2007-07-25 00:00:18 UTC
change QA contact

Comment 4 Daniel Berrange 2007-09-24 23:16:34 UTC
Fix this in an update quite a while ago. Then broke it again. Then fixed it again. 


Note You need to log in before you can comment on or make changes to this bug.