Bug 211233 - Possible usability improvements to "Locating installation media" page
Possible usability improvements to "Locating installation media" page
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On: 209479
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-17 19:17 EDT by Daniel Berrange
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:06:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2006-10-17 19:17:04 EDT
+++ This bug was initially created as a clone of Bug #209479 +++

Description of problem:
"Locating installation media" page has two URL fields: Install media URL,and an
optional kicksart URL.

Is there a way of minimizing the amount of URLs that need to be entered here? 
Will it have history of previous URLs that you have typed here?  (it's not quite
as bad as anaconda since at least you can copy and paste from a browser window)  

In particular, can there be:
- an option to install from local media?  (autodetected, so it knows if you have
a CD/DVD in the drive)
- for RHEL, knowledge about RHN or the satellite server you installed from, and
give the option to select a distro/kickstart from this server? 
One feature of RHN is the ability to store kickstart profiles:
https://rhn.redhat.com/rhn/help/reference/rhn410/en/s1-sm-systems.jsp#S2-SM-SYSTEM-KICKSTART
Should they be displayed here?

I can't see a way of doing this via the API:
  https://rhn.redhat.com/rhn/apidoc/
(though I guess the API can be expanded)

Version-Release number of selected component (if applicable):
virt-manager-0.2.3-2.fc6

-- Additional comment from dmalcolm@redhat.com on 2006-10-05 11:38 EST --
Created an attachment (id=137825)
Screenshot of the page


-- Additional comment from dmalcolm@redhat.com on 2006-10-05 11:40 EST --
Sorry to file RHEL-specific stuff under Fedora; maybe this bug should be split
up and the RHEL part moved to a new bug under the correct "Product"?

-- Additional comment from berrange@redhat.com on 2006-10-06 11:06 EST --
We already have plans to add support for remembering the last 'N' URLs entered. 

In theory we could support install of CD, but there is no way to change CD's
when the guest VM is running in paravirt guests, so for now that'll probably
lead to more problems that it solves.

So, for this bug we'll address the URL history. Could you enter a separate bug
for RHN integration - it is something that'll need much more
thought/investigation to decide to best way to approach it.
Comment 1 Hugh Brock 2006-10-18 15:53:39 EDT
URL history added
Comment 2 Brian Stein 2006-10-18 16:50:00 EDT
Patch is ready to go.
Comment 3 RHEL Product and Program Management 2006-10-18 17:05:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Jay Turner 2006-10-19 10:13:10 EDT
QE ack for RHEL5.
Comment 5 Daniel Berrange 2006-10-23 09:38:16 EDT
The fix for this issue has been built into virt-manager-0.2.5-1.el5

Note You need to log in before you can comment on or make changes to this bug.