Bug 211307 - gtk apps seg fault when "Subpixel Smoothing" enabled and when using X11 forwarding
gtk apps seg fault when "Subpixel Smoothing" enabled and when using X11 forwa...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cairo (Show other bugs)
rawhide
ppc64 Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 12:12 EDT by Ben Konrath
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.2.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-16 19:04:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
back trace from gdb of gtk-simple-with-label (3.41 KB, text/plain)
2006-10-18 12:12 EDT, Ben Konrath
no flags Details
glibc memory corruption output from gedit (ppc) (29.25 KB, text/plain)
2006-10-18 12:14 EDT, Ben Konrath
no flags Details
back trace from gdb of gtk-simple-with-label with all debuginfo packages installed (6.76 KB, text/plain)
2006-10-19 13:29 EDT, Ben Konrath
no flags Details

  None (edit)
Description Ben Konrath 2006-10-18 12:12:49 EDT
Description of problem:

Gtk applications seg fault in libcario for both ppc applications on ppc64 and
ppc64 applications. 

Version-Release number of selected component (if applicable):

cairo-1.2.4-1.fc6

How reproducible:

Always.

Steps to Reproduce:

1. Compile gtk-simple-with-label.c:
#include <gtk/gtk.h>
int main( int   argc, char *argv[] )
{
    GtkWidget *window;
    GtkWidget *label;
    gtk_init (&argc, &argv);
    window = gtk_window_new (GTK_WINDOW_TOPLEVEL);
    label = gtk_label_new ("Hello World");
    gtk_container_add (GTK_CONTAINER (window), label);
    gtk_widget_show (label);
    gtk_widget_show (window);
    gtk_main ();
    return 0;
}
==> gcc gtk-simple-with-label.c -o gtk-simple-with-label \
        `pkg-config --cflags --libs gtk+-2.0`

2. Run the program and notice the seg fault. 

I noticed that a simple app without text doesn't cause a seg fault - gtk-simple.c:
#include <gtk/gtk.h>
int main( int   argc, char *argv[] )
{
    GtkWidget *window;
    gtk_init (&argc, &argv);
    window = gtk_window_new (GTK_WINDOW_TOPLEVEL);
    gtk_widget_show  (window);
    gtk_main ();
    return 0;
}
==> gcc gtk-simple.c -o gtk-simple `pkg-config --cflags --libs gtk+-2.0`

Additional info:

All gtk apps exhibit this behaviour on both of the ppc64 boxes (G5s) we have
here in toronto. When I run gedit (32 bit), I get a glib memory corruption error
which I will attach.

People are welcome to login into tofu.toronto to test things out. We installed
the system on Oct 5 and gtk apps were working at that point. We have been
updating regularly so one of our updates must have caused this.
Comment 1 Ben Konrath 2006-10-18 12:12:49 EDT
Created attachment 138803 [details]
back trace from gdb of gtk-simple-with-label
Comment 2 Ben Konrath 2006-10-18 12:14:05 EDT
Created attachment 138804 [details]
glibc memory corruption output from gedit (ppc)
Comment 3 Yong Zheng 2006-10-18 21:54:39 EDT
In our local PPC64 box(POWER 4, with 4 processors), the bug cannot be
reproduced. The gt-simple and gedit application work well, we didnot get the
segment fault. The info of the machine is the following:

== Linux release==

FC6 Test 3

==kernel==

Linux plinuxt6 2.6.17-1.2630.fc6 #1 SMP Wed Sep 6 17:17:26 EDT 2006 ppc64 ppc64
ppc64 GNU/Linux

== cairo relevant package ==
[root@plinuxt6 /home/zhengyong/test]# rpm -qa | grep "cairo"
pycairo-1.2.0-1.1
cairo-devel-1.2.4-1.fc6
pycairo-devel-1.2.0-1.1
cairo-java-devel-1.0.5-2.fc6
cairo-1.2.4-1.fc6
cairo-1.2.4-1.fc6
cairo-java-1.0.5-2.fc6
cairo-devel-1.2.4-1.fc6

== gtk relevant packages ==
[root@plinuxt6 /home/zhengyong/test]# rpm -qa | grep "gtk"
pygtk2-2.9.6-2.fc6
usermode-gtk-1.86-1
gtksourceview-1.8.0-1.fc6
gtk2-engines-2.8.0-1.fc6
libswt3-gtk2-3.2.0-5.fc6
gtk2-devel-2.10.3-1.fc6
gtk2-engines-2.8.0-1.fc6
gtk2-2.10.3-1.fc6
gtk-doc-1.7-1.fc6
gtk2-2.10.3-1.fc6
gtkspell-2.0.11-2.1
gnome-python2-gtksourceview-2.16.0-1.fc6
pygtk2-devel-2.9.6-2.fc6
pygtk2-libglade-2.9.6-2.fc6
libgtk-java-2.8.6-3.fc6
gtk-sharp2-2.10.0-1.fc6
libgtk-java-devel-2.8.6-3.fc6
gtk2-devel-2.10.3-1.fc6
authconfig-gtk-5.3.6-1
gtkhtml3-3.12.0-1.fc6
pygtk2-devel-2.9.6-2.fc6
Comment 4 Ben Konrath 2006-10-19 13:29:30 EDT
Created attachment 138885 [details]
back trace from gdb of gtk-simple-with-label with all debuginfo packages installed

Ok, I investigated this a little more and here's the real steps to reproduce:

1) ssh into the ppc64 machine with X11Forwarding on (i.e. ssh -Y <machine
name>) from an i386 rawhide box

2) run gtk-simple-with-label

3) Open the Font Preferences dialog (i.e. System -> Preferences -> Fonts) and
enable "Subpixel Smoothing (LCDs)"

This last operation causes the seg fault. Gtk apps can't be run until the Font
Rendering is set back to "Best Shapes"	I'm not sure if this happens when you
are logged in locally because I can't get X to start on our ppc64 machine.

Software versions:

% rpm -q glib2 gtk2 pango cairo
glib2-2.12.3-2.fc6.ppc
glib2-2.12.3-2.fc6.ppc64
gtk2-2.10.4-4.fc6.ppc
gtk2-2.10.4-4.fc6.ppc64
pango-1.14.4-3.fc6.ppc
pango-1.14.4-3.fc6.ppc64
cairo-1.2.4-1.fc6.ppc64
cairo-1.2.4-1.fc6.ppc
Comment 5 Ben Konrath 2006-10-19 13:34:56 EDT
Behdad, is this an issue with pango?
Comment 6 Andrew Overholt 2006-10-25 16:44:19 EDT
Behdad thinks this is https://bugs.freedesktop.org/show_bug.cgi?id=7953
Comment 7 Behdad Esfahbod 2006-11-08 12:08:04 EST
Should be fixed with cairo 1.2.6.
Comment 8 Andrew Overholt 2006-11-16 19:04:54 EST
This is indeed fixed with cairo 1.2.6.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.