Bug 211325 - Get error "ncpmount: No such device in mount(2)" with ncpmount because ncp is missing from kernel 2.6.18-1.2200
Get error "ncpmount: No such device in mount(2)" with ncpmount because ncp is...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 212347 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 14:08 EDT by Chris Jenks
Modified: 2015-01-04 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-12 00:45:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Jenks 2006-10-18 14:08:06 EDT
Description of problem:

The command:
ncpmount -A USERSB -V /VOLUME/PATH -U MY.USERID.AT.WORK -P xxxxxx mount-point
/home/chris/H -m
fails since my last kernel update.

Version-Release number of selected component (if applicable):

My kernel was last updated from version 2.6.17-1.2187_FC5smp to
2.6.18-1.2200.fc5smp, and ncpfs is version 2.2.6-2

How reproducible:

Always.

Steps to Reproduce:
1. Boot into kernel 2.6.18-1.2200.fc5smp
2. Issue to above ncpmount command

Actual results:

Mount fails with error:
ncpmount: No such device in mount(2)

Expected results:
Successful mount (no text output)

Additional info:
I noticed from the configuration files that the NCP filesystem is built into the
2.6.17 kernel version but not version 2.6.18.
Comment 1 Daniela Jung 2006-10-20 06:14:26 EDT
This bug seems to be the same as bug 203663.
The Kernel-Module "ncpfs.ko" is missing.
Comment 2 Dave Jones 2006-10-21 02:06:35 EDT
fixed in cvs, will be in next update.
Comment 3 Dave Jones 2006-10-28 01:42:38 EDT
*** Bug 212347 has been marked as a duplicate of this bug. ***
Comment 4 Dave Jones 2006-11-12 00:45:27 EST
should be fixed in 2.6.18-1.2239.fc5 now in updates.

Note You need to log in before you can comment on or make changes to this bug.