Bug 211327 - Listen does not launch in default install on x86_64 machines, edit of launcher script is required.
Summary: Listen does not launch in default install on x86_64 machines, edit of launche...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: listen   
(Show other bugs)
Version: 5
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
Assignee: Haïkel Guémar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-18 18:14 UTC by Gian Paolo Mureddu
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 0.5-8.beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 12:18:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The attahced file is a rough patch for the right launcher script on x86_64 and possibly other 64-bit architectures. (225 bytes, patch)
2006-10-18 18:14 UTC, Gian Paolo Mureddu
no flags Details | Diff

Description Gian Paolo Mureddu 2006-10-18 18:14:12 UTC
Description of problem:
Listen launcher script in /usr/bin/listen does not point to the right .py (in
/usr/lib64) in x64_64 and possibly other 64-bit platforms.

Version-Release number of selected component (if applicable):


How reproducible:
Always. Has been there since a couple releases.

Steps to Reproduce:
1. install listen with yum
2. type "listen" in a console to get the error message about the .py file not
being found at the /usr/lib path.
3.
  
Actual results:
The program does not launch. Manual edit of the file is required for 64-bit
architectures.

Expected results:


Additional info:

Comment 1 Gian Paolo Mureddu 2006-10-18 18:14:12 UTC
Created attachment 138813 [details]
The attahced file is a rough patch for the right launcher script on x86_64 and possibly other 64-bit architectures.

Comment 2 Haïkel Guémar 2006-10-18 21:01:40 UTC
I have been emailed about this, it will be fixed by the next update.
It's due to Listen not respecting FHS and I don't have any x86_64 box to test my
packages.
One question: after replacing lib by lib64 in /usr/bin/listen, does the
application launch or it still fails ?

Comment 3 Gian Paolo Mureddu 2006-10-20 03:41:13 UTC
Hi, after changing /usr/lib for /usr/lib64 it works as expected. Thanks for your
answer.

Comment 4 Haïkel Guémar 2006-11-01 12:18:12 UTC
fixed by current release.


Note You need to log in before you can comment on or make changes to this bug.