Bug 211349 - no sound and crash using module intel8x0 (sis ac97 laptop clevo d631s)
no sound and crash using module intel8x0 (sis ac97 laptop clevo d631s)
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 15:40 EDT by Nadav Kavalerchik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 10:17:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sound related log file generated with system-config-sound (25.06 KB, text/plain)
2006-10-18 15:40 EDT, Nadav Kavalerchik
no flags Details

  None (edit)
Description Nadav Kavalerchik 2006-10-18 15:40:26 EDT
Description of problem:
modprobe-ing the snd-intel8x0 module into kernel (2.6.18-1.2798.fc6) crashes.
not abling to find correct irq (bios is assigning irq 0).

result : no sound

see attached file with system sound related info and log.

btw. loading Knoppix 4.0.2 live cd. loads i810_audio sound module and all works
well.on

Version-Release number of selected component (if applicable):
alsa 1.0.12

How reproducible:
install and boot a Clevo d631s laptop with latest fedora test3 os

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Nadav Kavalerchik 2006-10-18 15:40:26 EDT
Created attachment 138825 [details]
sound related log file generated with system-config-sound
Comment 2 Martin Stransky 2006-10-23 06:45:40 EDT
Yepp, you're right. You can:

- check new drivers, how-to is here: http://people.redhat.com/stransky/alsa
- check some kernel parameters (acpi=off, like here:
http://ubuntuforums.org/archive/index.php/t-21403.html)
- report this problem to ALSA project (www.alsa-project.org) and attach the log
file there
Comment 3 Nadav Kavalerchik 2006-11-18 13:11:02 EST
i tried many things, none worked :-( i also couldn't compile an rt2500 wireless
module for my edimax pcmcia card so i moved to debian and all works just fine.
( on an older kernel version 2.6.17 ) so i guess the modules of an olders kernel
might have fix it. but now it's to late :-)

i still use fedora devel on my main desktop computer, thu. happyly :-)

thanks :-)
Comment 4 Martin Stransky 2006-12-14 06:31:33 EST
You can check the latest drivers / packages (ALSA 1.0.14rc1)
How-to is here:

http://people.redhat.com/stransky/alsa/

Comment 5 Nadav Kavalerchik 2006-12-14 07:50:28 EST
you can close it, because i have no way to check it out. (i've installed debian
on this machine :-)

(or maybe... i'll check out the live cd if it has the latest ALSA drivers ?)
Comment 6 Martin Stransky 2006-12-14 10:17:21 EST
Aha, okay, no problem, forget it...

Note You need to log in before you can comment on or make changes to this bug.