Bug 211418 - Modify gfs2_jadd to use the new inode flag routines in fs.h instead of iflags.h
Modify gfs2_jadd to use the new inode flag routines in fs.h instead of iflags.h
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gfs2-utils (Show other bugs)
5.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Abhijith Das
GFS Bugs
ReviewOct20,ReviewOct23
:
: 211473 (view as bug list)
Depends On: 211583
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-18 19:34 EDT by Abhijith Das
Modified: 2010-01-11 22:36 EST (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:29:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijith Das 2006-10-18 19:34:50 EDT
Description of problem:
Modify gfs2_jadd to use the new inode flag routines in fs.h instead of iflags.h.  
iflags.h is not in the upstream kernel and should not be supported going forward.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rob Kenna 2006-10-18 21:48:20 EDT
I think this needs to be in B2, but am not sure we've got the header issues
settled.  If the header items are settled quickly, then this needs to be done. 
So I'm marking this for a beta blocker as the header issue is a potential api
item.  If the header file changes don't go in then we'll need to live with a non
upstream  form that we have today.  The header issue has gone to rhkernel-list.
Comment 2 Rob Kenna 2006-10-19 14:19:15 EDT
*** Bug 211473 has been marked as a duplicate of this bug. ***
Comment 5 Kiersten (Kerri) Anderson 2006-10-23 07:42:20 EDT
Patches have been posted to rhkernel list.  Setting DEVEL ACK.  Need to wait
until a kernel is available before committing changes to our source base.
Comment 11 Abhijith Das 2006-10-26 14:43:28 EDT
cvs commit -m "bz 211418. Modified gfs2_tool and gfs2_jadd to use the new inode
flags in fs.h instead of deprecated iflags.h" tool/misc.c mkfs/gfs2_mkfs.h
mkfs/main_jadd.c
Checking in tool/misc.c;
/cvs/cluster/cluster/gfs2/tool/misc.c,v  <--  misc.c
new revision: 1.8; previous revision: 1.7
done
Checking in mkfs/gfs2_mkfs.h;
/cvs/cluster/cluster/gfs2/mkfs/gfs2_mkfs.h,v  <--  gfs2_mkfs.h
new revision: 1.9; previous revision: 1.8
done
Checking in mkfs/main_jadd.c;
/cvs/cluster/cluster/gfs2/mkfs/main_jadd.c,v  <--  main_jadd.c
new revision: 1.10; previous revision: 1.9
done

Note You need to log in before you can comment on or make changes to this bug.