Bug 21142 - rpm-3.0.6_IBM_patch_001 configure should substitute OBJDUMP
rpm-3.0.6_IBM_patch_001 configure should substitute OBJDUMP
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-20 15:28 EST by Paul Shearer
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 15:45:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpm-3.0.6_IBM_patch_001 Patch file (2.00 KB, patch)
2000-11-20 15:45 EST, Paul Shearer
no flags Details | Diff

  None (edit)
Description Paul Shearer 2000-11-20 15:28:45 EST
IBM SPTS: 254361

IBM PATCH: rpm-3.0.6_IBM_patch_001

Submitter: paulsh@us.ibm.com
                Paul Shearer

Product: Red Hat Linux
Version: 6.2
Component: rpm-3.0.6
Platform:
OS: IBM ptx
uname -a: DYNIX/ptx eng2 4.0 V4.6.0 i386

Summary:

        configure and popt/configure needs to substitute OBJDUMP

Description:

OVERVIEW DESCRIPTION:

        Makefile.in
        popt/Makefile.in

        both contain the line:

        OBJDUMP = @OBJDUMP@

        This is unchanged in the Makefile since no substitute
        command is available to replace @OBJDUMP@ .

        To clean this up it configure should substitute:

        s%@OBJDUMP@%$OBJDUMP%g

        The patch below shows the change needed to configure.
        I don't know the corresponding change needed to configure.in
        since I am not regenerating configure.
        So you may need to patch configure.in to make this change.


STEPS TO REPRODUCE:

        ./configure
        See the OBJDUMP = @OBJDUMP@ line in:
        ./Makefile
        popt/Makefile


ACTUAL RESULTS:

        Makefile line:
        OBJDUMP = @OBJDUMP@

EXPECTED RESULTS:

        Makefile line: (if $OBJDUMP is null)
        OBJDUMP =

BUILD DATE & PLATFORM:

        N/A

ADDITIONAL BUILDS AND PLATFORMS:

        N/A

ADDITIONAL INFORMATION: (crash info)

        N/A

UNIX STACK TRACE:

        N/A

SAMPLE PATCH:

IBM patch sequence number: rpm-3.0.6_IBM_patch_001


List of files patched followed by RCS or SCCS ident lines.
==========================================================

configure
popt/configure


Patch to fix the files
======================
*** 1.2 2000/11/03 22:31:34
--- configure   2000/11/08 10:00:35
***************
*** 9143,9148 ****
--- 9143,9149 ----
  s%@__NM@%$__NM%g
  s%@__OBJCOPY@%$__OBJCOPY%g
  s%@__OBJDUMP@%$__OBJDUMP%g
+ s%@OBJDUMP@%$OBJDUMP%g
  s%@__STRIP@%$__STRIP%g
  s%@LIBOBJS@%$LIBOBJS%g
  s%@ALLOCA@%$ALLOCA%g
*** 1.1 2000/11/02 09:33:16
--- popt/configure      2000/11/15 19:37:29
***************
*** 4427,4432 ****
--- 4427,4433 ----
  s%@MKINSTALLDIRS@%$MKINSTALLDIRS%g
  s%@l@%$l%g
  s%@POPT_SOURCE_PATH@%$POPT_SOURCE_PATH%g
+ s%@OBJDUMP@%$OBJDUMP%g

  CEOF
  EOF
Comment 1 Paul Shearer 2000-11-20 15:45:36 EST
Created attachment 5567 [details]
rpm-3.0.6_IBM_patch_001 Patch file
Comment 2 Jeff Johnson 2000-12-03 14:07:10 EST
Fixed in CVS, should be in rpm-4.0.1-0.15 and later.

Note You need to log in before you can comment on or make changes to this bug.