Bug 211436 - Wrongly rendered as_IN font
Wrongly rendered as_IN font
Status: CLOSED DUPLICATE of bug 209975
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: qt (Show other bugs)
5.0
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
: i18n, Patch
Depends On: 211435
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 04:31 EDT by Amitakhya Phukan
Modified: 2012-05-19 19:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-02 08:23:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modification in the qscriptengine_x11.cpp for assamese rendering issue (693 bytes, patch)
2006-10-19 06:24 EDT, Sachin Tawniya
no flags Details | Diff
patch (646 bytes, patch)
2006-10-20 07:50 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Amitakhya Phukan 2006-10-19 04:31:37 EDT
+++ This bug was initially created as a clone of Bug #211435 +++

Description of problem:
Rendering of Assamese consonant character "Khanda Ta" not proper. Unicode
Character 09CE.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Open kedit.
2. Press "Shift+8" after selecting Assamese Phonetic keyboard layout.
3.
  
Actual results:
The character is not rendered properly.

Expected results:
The character should be rendered properly.

Additional info:
Attached is a screenshot of Kedit and Gedit. In Gedit, it is rendered properly.

-- Additional comment from aphukan@redhat.com on 2006-10-19 04:19 EST --
Created an attachment (id=138865)
wrong rendering in kedit
Comment 1 Amitakhya Phukan 2006-10-19 05:28:04 EDT
the character 09CE is a special consonant character in Assamese lanuage and is
frequently used. The QT engine has given it the status of this character as
unknown. Hence the dotted circle is appearing as can be seen in the screenshot.
Possible solution is changing the Unknown tag to Consonant.
Comment 2 Sachin Tawniya 2006-10-19 06:24:12 EDT
Created attachment 138871 [details]
modification in the qscriptengine_x11.cpp for assamese rendering issue
Comment 3 Akira TAGOH 2006-10-19 08:28:20 EDT
Sachin, can you polish your patch up more? it looks like your patch contains
irrelevant change that just add white-space stuff. it would be nice if
your patch just has minimal changeset.
Comment 4 Akira TAGOH 2006-10-20 07:50:34 EDT
Created attachment 138962 [details]
patch

just disable the unnecessary changes in chunk.
Comment 5 Ngo Than 2006-10-20 12:59:50 EDT
the fix will be included in qt-3.3.6-14.Sachin, thanks for the fix
Comment 7 RHEL Product and Program Management 2007-05-01 11:33:15 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 Ngo Than 2007-05-02 08:23:55 EDT
could 

*** This bug has been marked as a duplicate of 209975 ***

Note You need to log in before you can comment on or make changes to this bug.