Bug 211446 - Raritan KVM USB dongle needs to be added to the USB HID blacklist
Raritan KVM USB dongle needs to be added to the USB HID blacklist
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: John Feeney
Brian Brock
: Regression
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-10-19 07:02 EDT by Raghavendra Biligiri
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 09:52:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that fixes this issue.Patch has been accepted upstream. (1.18 KB, patch)
2006-10-19 07:10 EDT, Raghavendra Biligiri
no flags Details | Diff

  None (edit)
Description Raghavendra Biligiri 2006-10-19 07:02:49 EDT
Description of problem:
During Installation the host tries to enumerate the keyboard/mouse dongle for 
the Raritan KVM.At this time timeouts have been observed. So if the system has 
USB Floppy/CDROM and if the Raritan USB KVM Dongle is being enumerated first 
then due to these timeouts the usb-storage driver will not be loaded.So the USB 
storage devices will be inaccessible.
Adding the Raritan KVM USB dongle to the blacklist fixes this issue


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Raghavendra Biligiri 2006-10-19 07:10:58 EDT
Created attachment 138874 [details]
Patch that fixes this issue.Patch has been accepted upstream.
Comment 3 RHEL Product and Program Management 2006-10-26 09:24:04 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Peter Martuccelli 2006-10-26 10:10:13 EDT
John - review this issue for R5, obtain a KVM for testing as required.
Comment 5 Samuel Benjamin 2006-10-27 13:31:50 EDT
FTR (for the record) .. patch is provided by Dell to fix this issue.
Comment 6 Amit Bhutani 2006-11-03 01:22:55 EST
Raising severity as the Raritan KVM USB dongle is commonly used in *all* of
Dell's test labs.

Dell will be more than happy to test and post results on the test package, so
there shouldn't be a need to send H/W to RH. As a matter of fact, as per comment
#1, issues has already been regressed successfully as fixed with the proposed
patch. Can someone from RH please review and comment on the patch ??
Comment 7 John Feeney 2006-11-07 15:38:47 EST
Code with patch has been built by Brew and can be tested
(/mnt/brew/scratch/jfeeney/task_355953). Can be tested by Dell.
Comment 8 Raghavendra Biligiri 2006-11-09 02:39:12 EST
Tested the patch provided with the test kernel.It works fine.
Comment 9 Linda Wang 2006-11-17 11:38:33 EST
patch posted on 11/09/06
Comment 10 Jay Turner 2006-11-20 13:31:03 EST
QE ack for RHEL5.
Comment 11 Samuel Benjamin 2006-11-29 08:41:34 EST
Dell verified fix. Requesting RH to close.
Comment 12 Don Zickus 2006-12-04 13:35:42 EST
in 2.6.18-1.2789.el5
Comment 13 Raghavendra Biligiri 2006-12-22 10:23:15 EST
Issue not reproducible on RHEL5-RC Snapshot5(kernel-2.6.18-1.2910.el5). 
Comment 14 Amit Bhutani 2006-12-22 10:47:44 EST
Marking issue as VERIFIED based on comment #13.

RH- Please close.
Comment 15 Jay Turner 2007-01-03 09:52:29 EST
Closing out based on comment 13.

Note You need to log in before you can comment on or make changes to this bug.