Bug 211477 - Too many files open error
Too many files open error
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 13:07 EDT by Joshua Rosen
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-19 14:46:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2006-10-19 13:07:11 EDT
Description of problem:I'm getting the "Too many files open" error. I keep all
of my e-mail (sans spam of course) and after a number of years I've reached the
limit of how many email files Evolution can handle. I assume that there is some
sort structure that has a limit on how big it can be or maybe there is just some
file limit variable somewhere. It would be nice it the limit value would be
increased, I'd jack it up 10X which should be enough so that no one reaches the
limit again.


Version-Release number of selected component (if applicable): 2.6.3


How reproducible:


Steps to Reproduce:
1. You need thousands of mail messages
2. When you reach the limit (whatever it is) you'll start to get this error
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2006-10-19 14:46:03 EDT
Hi, this bug has been fixed in Fedora Core 6.  The problem was that Evolution
was opening thousands of FIFO pipes at start-up and chewing up all your
available file descriptors.

With Fedora Core 6 scheduled for release next week there are no plans to
backport the fix to Fedora Core 5.  But as a temporary workaround you can
increase your file descriptor limit before invoking Evolution like so:

   # ulimit -n <some-really-big-number>; evolution

Note You need to log in before you can comment on or make changes to this bug.