Bug 211550 - Moused-over city/timezone identity is not clear
Moused-over city/timezone identity is not clear
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 17:52 EDT by Máirín Duffy
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-18 22:51:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
mockup of city/timezone contextual label (122.72 KB, image/png)
2006-10-19 17:52 EDT, Máirín Duffy
no flags Details

  None (edit)
Description Máirín Duffy 2006-10-19 17:52:14 EDT
Description of problem:

When I mouse over a city/time zone dot on the map, it is not clear to me which
city/time zone it is I've highlighted. The status bar is too far away from my
area of focus and not visible/apparenty enough to be useful. While making the
text in the status bar bolder and larger might make these labels more obvious, I
think even better is to display the city/time zone name in the user's current
area of focus. 

See attached mockup for a suggestion.
Comment 1 Máirín Duffy 2006-10-19 17:52:14 EDT
Created attachment 138921 [details]
mockup of city/timezone contextual label
Comment 2 Nils Philippsen 2007-03-18 22:51:17 EDT
system-config-date-1.8.90 which is building right now displays the highlighted
city besides its marker in the map.

Note #1 that I had to do an ugly yellow backdrop for the label so it can be read
anywhere on the map. Ideas how this can be solved better welcome.

Note #2 that there is no statusbar anymore (and no methods thereof, Chris, sorry
for the short notice) but a label that shows the currently selected city,
(subregion,) region and comments at the same place -- the treeview doesn't show
all needed info at once but is necessary for the non-geographic timezones or if
one can't locate himself on the map ;-). As an alternative/augmentation I
implemented the currently selected city to be shown besides its marker, but
disabled it, because without a backdrop it'd be difficult to read and with one
it would possibly hide neighboring cities. Ideas?

Note #3 that the label reads "City, (Subregion,) Region" like in your mockup,
but somehow this doesn't sound well anywhere outside of Australia, e.g. "Berlin,
Europe" just sounds strange (it should at least be "Berlin, Germany" but tzdata
doesn't hold this info and AFAIK we don't want to call certain countries
countries for certain reasons anyway ;-). Should I make that just 'City' instead?

Please test and tell me what you think (and don't hold me responsible for the
jumpiness when zooming in/out or of the panning when zoomed in, these seem like
gnomecanvas "features", the latter only happens when dragging the mouse too fast).

Note You need to log in before you can comment on or make changes to this bug.