Bug 211561 - Kernel Crash when mounting ReiserFS partition created in Debian [[@__list_add]] [[@ pdflush]]
Kernel Crash when mounting ReiserFS partition created in Debian [[@__list_add...
Status: CLOSED DUPLICATE of bug 220756
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-19 20:55 EDT by irixman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-23 17:28:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Image of crash (940.71 KB, image/jpeg)
2006-10-19 22:04 EDT, irixman
no flags Details
First page of crash data (1.04 MB, image/jpeg)
2006-10-24 19:43 EDT, irixman
no flags Details
Second page of crash data (761.55 KB, image/jpeg)
2006-10-24 19:44 EDT, irixman
no flags Details
Page 3 of crash data (1009.98 KB, image/jpeg)
2006-10-24 19:45 EDT, irixman
no flags Details

  None (edit)
Description irixman 2006-10-19 20:55:45 EDT
rpm -q kernel
kernel-2.6.18-1.2200.fc5

When loading a clean 2200 kernel, the system hangs during the graphical boot
near "Starting Network" (or similar, can't remember exact label). If I kill the
X server, I see the bottom half of a panic.

IP was sync_super. It was primarilally unreadable. Installing kdump now, wanted
to submit the report pre-reboot.
Comment 1 Dave Jones 2006-10-19 20:57:53 EDT
if you boot with vga=1 you should get more lines of text on the screen, so
should be able to capture a whole trace.

(Attaching a photo of the screen is ok btw if you have a camera and want to save
a bunch of typing).
Comment 2 irixman 2006-10-19 22:04:25 EDT
Created attachment 138935 [details]
Image of crash

I am sorry about the terrible quality of the photo -- wouldn't work without the
flash, wouldn't work with the flash... :)

There was more of the oops before that, and I swear that there was a panic
rather than just the oops, etc...

A possible thought: /home never correctly mounts on my current kernel (2054),
unless I _manually_ do a mount /home. /home is a reiserfs partition that was
created under my previous Debian install.

I am pulling the mount line from fstab and checking it out.
Comment 3 irixman 2006-10-19 22:14:35 EDT
So, that did it. Removing the automatic mount line allowed me to get into the
system. Manually mounting the partition when booted is fine -- no oops, no
panic, no nothin'!
Comment 4 Dave Jones 2006-10-19 23:53:41 EDT
hmm, as thought the top of the oops is missing. Can you try booting with vga=1

Maybe add a 'sleep 60' or the like in /etc/rc.d/rc.sysinit too after the mount
command at 594 to make it easier to capture the screen without the follow-on noise.
Comment 5 irixman 2006-10-24 12:52:23 EDT
vga=1 changed the text style for a moment, but then went back to the pictured text.

Adding that sleep, will report back later today :)
Comment 6 irixman 2006-10-24 19:41:51 EDT
OK, 3 pictures inbound which are completely terrible due to my camera...
probably completely impossible to read. I can install kdump if someone gives me
a quick howto on the topic. Tried one I found in a bug about documentation,
didn't work.
Comment 7 irixman 2006-10-24 19:43:25 EDT
Created attachment 139286 [details]
First page of crash data
Comment 8 irixman 2006-10-24 19:44:28 EDT
Created attachment 139287 [details]
Second page of crash data
Comment 9 irixman 2006-10-24 19:45:38 EDT
Created attachment 139288 [details]
Page 3 of crash data
Comment 10 Dave Jones 2006-11-20 16:34:10 EST
unfortunatly the FC5 kdump stuff is incomplete so that isn't really an option here.

And yes, those pics were impossible to read :-)

Hmm. Not sure what else to suggest here. I'll take a look through the post .18
commits upstream and see if there's any obvious reiserfs fixes, though I don't
recall seeing anything recently.
Comment 11 Eric Sandeen 2007-04-23 17:28:54 EDT
The crash is fixed in newer kernels; not sure about the failure to mount via
fstab, with manual mounts succeeding.  Looks like a known deficiency in
reiserfs, pls see the other bug.

*** This bug has been marked as a duplicate of 220756 ***

Note You need to log in before you can comment on or make changes to this bug.