Bug 211583 - iflags.h is not upstream
iflags.h is not upstream
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Whitehouse
Dean Jansa
:
Depends On:
Blocks: 204760 211418
  Show dependency treegraph
 
Reported: 2006-10-20 05:32 EDT by Steve Whitehouse
Modified: 2009-05-27 23:33 EDT (History)
5 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 16:32:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to remove iflags.h and add flags to fs.h instead (10.46 KB, patch)
2006-10-20 07:34 EDT, Steve Whitehouse
no flags Details | Diff

  None (edit)
Description Steve Whitehouse 2006-10-20 05:32:06 EDT
The iflags.h header file is not the solution adopted by upstream for the inode
flags. In the upstream kernel, the flags are in fs.h. As a result we do not want
to leave iflags.h in RHEL since it would make a new interface available which
diverges from the upstream kernel. It is perfectly possible for GFS2 to use the
constants in fs.h which we can backport from upstream.

It is a relatively minor change. None of the flag values can change since they
are set in stone, mostly by ext2/3.
Comment 1 Steve Whitehouse 2006-10-20 07:34:25 EDT
Created attachment 138960 [details]
Patch to remove iflags.h and add flags to fs.h instead

This is a patch to remove iflags.h and add the flags into fs.h as per upstream.
Its consists of two components. The first is an excerpt from David Howell's
patch:

http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=36695673b012096228ebdc1b39a6a5850daa474e


I've just taken the bit which adds the constants to fs.h as that the only bit
which GFS2 needs. The other is the patch (also upstream) which I wrote to use
the flags in fs.h shortly before Linus pulled the GFS2 tree for the first time.


http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=128e5ebaf8abbda375bba82690b09630003c9213
Comment 2 Kiersten (Kerri) Anderson 2006-10-20 10:02:24 EDT
Going to change this one to kernel component since the change is to both gfs2
and fs.h.  I will let Linda devel ack it.
Comment 3 RHEL Product and Program Management 2006-10-20 10:18:47 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 5 Don Zickus 2006-10-25 18:24:42 EDT
in kernel-2.6.18-1.2737.el5

Note You need to log in before you can comment on or make changes to this bug.