Bug 211621 - kernel-xen shows up in a surprising place
kernel-xen shows up in a surprising place
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gregorovic
Daniel Riek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 10:41 EDT by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-25 11:02:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-10-20 10:41:04 EDT
I was trying to install RHEL5-Client as a xen guest, and had to 
customize the package list to make sure that the kernel-xen is included.

a) It would be good if anaconda knew that it runs in a xen vm, and automatically
   picks the right kernel

b) the kernel-xen package does not show up in "Virtualization" where I looked
for it, but in "Uncategorized/Miscellaneous packages"
Comment 1 RHEL Product and Program Management 2006-10-24 15:30:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Dennis Gregorovic 2006-11-30 15:45:46 EST
The kernel-xen package is in comps.xml twice.  Once in the "Miscellaneous
Included Packages" group and once in the "Virtualization" group.  Jeremy can
explain why this is the case.  
Comment 3 Jeremy Katz 2006-11-30 16:40:18 EST
(In reply to comment #0)
> a) It would be good if anaconda knew that it runs in a xen vm, and automatically
>    picks the right kernel

The right thing does happen here -- if you have a case where it doesn't, please
show me :)  But I've done lots of PV installs with the right thing happening...

> b) the kernel-xen package does not show up in "Virtualization" where I looked
> for it, but in "Uncategorized/Miscellaneous packages"

Miscellaneous packages shouldn't even be visible as a group...
Comment 4 Jeremy Katz 2006-11-30 16:48:11 EST
(In reply to comment #2)
> The kernel-xen package is in comps.xml twice.  Once in the "Miscellaneous
> Included Packages" group and once in the "Virtualization" group.  Jeremy can
> explain why this is the case.  

It's in the virt group so that if you're installing a dom0 (and thus select that
you want virt), you get the xen kernel installed.  

It's in miscallvars because otherwise, you'd have to have a virt installation
key to install.  Which isn't what is wanted.  The entire existence of
miscallvars is just a hack due to the how and why of RHEL tree composes not
sucking in all the packages and making them available to everyone.
Comment 5 Dennis Gregorovic 2006-11-30 18:27:19 EST
Matthias, can you verify in a recent tree the problems you reported?
Comment 6 Matthias Clasen 2006-11-30 18:31:48 EST
When I last tried an install on Tuesday, the tree was not installable due to
anaconda choking on _getNodes or something... 

So I couldn't verify it, no.
Comment 7 Dennis Gregorovic 2007-01-05 17:34:53 EST
Can you try again with a more recent tree?
Comment 8 Matthias Clasen 2007-01-08 14:08:08 EST
I'd much rather see qa verify this - they are doing tons of installs anyway,
whereas I would have to interrupt my regular duties just for doing a test install...
Comment 9 Jay Turner 2007-01-08 16:02:47 EST
Moving to NEEDINFO from myself so that I remember to test.
Comment 10 Jay Turner 2007-01-19 06:28:50 EST
I'm not seeing any oddities with the latest trees (20070118.nightly)  kernel-xen
actually isn't even appearing in package selection (being selected behind the
scenes) and the miscellaneous grouping isn't visible in either Client nor Server.
Comment 11 Jay Turner 2007-01-25 11:02:30 EST
Closing out.

Note You need to log in before you can comment on or make changes to this bug.