Bug 211640 - escapes error messages
escapes error messages
Status: CLOSED DUPLICATE of bug 219517
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 12:03 EDT by Bill Nottingham
Modified: 2014-03-16 23:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-06 16:38:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2006-10-20 12:03:54 EDT
Description of problem:

python-urlgrabber appears to use strerror() from glibc; however, it
does escaping on error messages, so anything run in a non-en_US locale
can get mangled.

Example, using ja_JP:

Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Repository 'workstation' is missing name in configuration, using id
Repository 'client' is missing name in configuration, using id
This system is not registered with RHN.
RHN support will be disabled.
Setting up Upgrade Process
Setting up repositories
http://porkchop.redhat.com/rel-eng/RHEL5-Client-20061019.1/4.91/x86_64/os/Workstation/repo
data/repomd.xml: [Errno 4] IOError: <urlopen error (-3,
'\xe5\x90\x8d\xe5\x89\x8d\xe8\xa7\
xa3\xe6\xb1\xba\xe6\x99\x82\xe3\x81\xae\xe4\xb8\x80\xe6\x99\x82\xe7\x9a\x84\xe3\x81\xaa\xe
5\xa4\xb1\xe6\x95\x97')>
Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: workstation
Comment 1 Jeremy Katz 2006-10-20 14:19:59 EDT
I vaguely remember another bug on this and after doing some poking through, it
seemed to be actually a python problem
Comment 2 Jeremy Katz 2007-01-06 16:38:44 EST

*** This bug has been marked as a duplicate of 219517 ***

Note You need to log in before you can comment on or make changes to this bug.