Bug 21169 - stat(2) manpage falsely claims S_ISLNK is POSIX
Summary: stat(2) manpage falsely claims S_ISLNK is POSIX
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: man-pages (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Wil Harris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-21 10:12 UTC by iwi
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-21 10:12:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description iwi 2000-11-21 10:12:55 UTC
The stat(2) manpage implies that S_ISLNK is a POSIX macro.

In fact, it seems to be a GNU extension.

    http://www.linuxbase.org/spec/libref.html

(and likewise S_ISSOCK)

This caused me to develop code on a RedHat machine, which
then turned out not to port cleanly to other systems.

Comment 1 Trond Eivind Glomsrxd 2000-11-21 20:31:10 UTC
Fixed in man-pages-1.31-4, which should make it to Rawhide some day. Thanks for
the report, I'll upstream the patch.


Note You need to log in before you can comment on or make changes to this bug.