Bug 211693 - OSA-Dispatcher leaks memory and CPU
OSA-Dispatcher leaks memory and CPU
Status: CLOSED DUPLICATE of bug 222988
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Beth Nackashi
:
Depends On:
Blocks: 173427
  Show dependency treegraph
 
Reported: 2006-10-20 16:50 EDT by James Bowes
Modified: 2013-01-10 04:51 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 11:49:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Bowes 2006-10-20 16:50:05 EDT
on startup, osa-dispatcher used 1% cpu and 0.5% memory on my rlx machine.
After about two days, it now uses 18% cpu and 0.7% memory.
Comment 1 James Bowes 2007-01-24 12:58:27 EST
jabber_lib.py (_get_callbacks_from_list) seems to be the culprit.

NCALLS PERCALL
1755   0.007
5211   0.019
93959  0.302

The time spend in this function increases as the program runs.
Comment 2 Mike McCune 2007-04-04 13:47:15 EDT
Shannon, can you investigate this?
Comment 3 Shannon Hughes 2007-04-10 11:49:41 EDT

*** This bug has been marked as a duplicate of 222988 ***

Note You need to log in before you can comment on or make changes to this bug.