Bug 211697 - xm create <guest> gives an inscrutable error message when it picks up the wrong config file
xm create <guest> gives an inscrutable error message when it picks up the wro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 17:08 EDT by Hugh Brock
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:33:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix proposal (1.10 KB, patch)
2006-10-20 17:30 EDT, Glauber Costa
no flags Details | Diff

  None (edit)
Description Hugh Brock 2006-10-20 17:08:53 EDT
Description of problem:
xm create <guest> searches for a file named <guest> on the path. If it finds one
before the correct one in /etc/xen, it will try to use it; if the file is a
binary file, the error message complains about unparseable characters in the
file, rather than indicating that it may have found the wrong file.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Place a binary file named <guest> on the search path
2. type "xm create <guest>"
3.
  
Actual results:
Error message about unexpected binary characters in config file

Expected results:
Error message about finding a file with the same name as the config file that is
not the config file

Additional info:
Comment 1 Glauber Costa 2006-10-20 17:30:08 EDT
Created attachment 139033 [details]
Fix proposal

I've just sent this patch to mainstream, which gives a more descriptive error
message.
Comment 2 Glauber Costa 2006-10-27 09:23:03 EDT
just got upstream 
Comment 3 RHEL Product and Program Management 2006-10-27 09:25:31 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 4 Rod Nayfield 2006-10-27 09:38:33 EDT
I have seen this problem manifest itself in milestone 6.   This patch is very
necessary, especially since our tools don't offer naming conventions (no .img by
default) ... so if you are in /xen you can't start machines when diskname ==
config name
Comment 5 Rik van Riel 2006-11-08 21:47:03 EST
Damnit, no QA ack yet :(
Comment 7 Jay Turner 2006-11-20 15:14:12 EST
QE ack for RHEL5.
Comment 8 Rik van Riel 2006-12-05 17:09:50 EST
in 3.0.3-9.el5
Comment 9 RHEL Product and Program Management 2006-12-22 20:33:31 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.