Bug 21173 - jed edt mode application keypad fails
jed edt mode application keypad fails
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: jed (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 06:50 EST by nvwarr
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-21 11:46:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nvwarr 2000-11-21 06:50:21 EST
When jed is configured to use edt mode. i.e. .jedrc contains () =
evalfile("edt");  edt-style functions bound to the numeric keypad do not
work correctly when in application mode. For example, the period key of the
numeric keypad should give a period when in numeric mode and should do a
"smart_set_mark_cmd" in application mode. Instead, these keys work as if
they were in numeric mode at all times. Those edt-style functions which are
mapped to keys other than the numeric keypad work as expected. In
particular, the "Gold" key (Numlock) writes a message to indicate it is
correctly toggling between application and numeric mode.

Note that xjed does not have this problem. (I have no jed related
Xresources). With RH6.2 this problem did not exist either. However,
downgrading jed and/or slang to the RH6.2 versions does _not_ fix the
problem.
Comment 1 Bill Nottingham 2000-11-21 11:05:13 EST
Does the failure in normal mode (not xjed) fail on both the console
and in an xterm/gnome-term/whatever, or just under X?
Comment 2 nvwarr 2000-11-21 11:46:17 EST
I've just tested it under other terminals and the failure in normal mode only
occurs in an xterm window, not in kterm, nor gnome-terminal nor on the console.

Perhaps it is something with xterm then?
Comment 3 nvwarr 2000-11-22 07:57:41 EST
I can now confirm that the problem is not with jed, but with xterm. Downgrading
xterm to the version from RH6.2 (leaving the rest of XFree 4.0 as in 7.0) fixes
the problem with jed.

Note You need to log in before you can comment on or make changes to this bug.