Bug 211739 - bash quoting broken
bash quoting broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-21 11:43 EDT by Josh Boyer
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 06:05:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Boyer 2006-10-21 11:43:37 EDT
Description of problem:

Quilt fails to build on FC-5 because it's configure script detects the following
bug in the bash:

checking whether /bin/bash quoting works... no
configure: error:
You have a version of `bash' which suffers from a quoting bug.
This is a known bug of bash 3.1, which was fixed by patch bash31-011.
You can get this patch at ftp://ftp.gnu.org/gnu/bash/


Version-Release number of selected component (if applicable):

bash-3.1-6.2

How reproducible:

Always

Steps to Reproduce:
1. Attempt to build quilt
2.
3.
  
Actual results:

Build fails

Expected results:

Build doesn't hit this bash configure problem

Additional info:

The patch to fix this is included in the configure output.
Comment 1 Josh Boyer 2006-10-21 11:44:57 EDT
Note that quilt builds just fine on rawhide (soon to be FC-6) so that version
must have the patch to fix the issue.
Comment 2 Tim Waugh 2006-10-23 12:21:25 EDT
I'm going to push a bash-3.1-9.fc5.1 package to updates-testing.  Please try it
out when it appears.
Comment 3 Josh Boyer 2006-10-24 15:57:25 EDT
(In reply to comment #2)
> I'm going to push a bash-3.1-9.fc5.1 package to updates-testing.  Please try it
> out when it appears.

I installed this today and quilt built fine.  Regular bash operations seem to be
functioning as well.  The update looks good, thanks!

Comment 4 Tim Waugh 2006-10-30 06:05:01 EST
Update pushed.

Note You need to log in before you can comment on or make changes to this bug.