Bug 211754 - Can no longer mount windows shares
Can no longer mount windows shares
Status: CLOSED DUPLICATE of bug 211753
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-21 17:39 EDT by vaughn miller
Modified: 2015-01-04 17:29 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-21 18:02:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vaughn miller 2006-10-21 17:39:23 EDT
Description of problem:
I was on 2.6.17-1.2174_FC5. After doing an update {yum} to 2.6.18-1.2200.fc5 I
can no longer mount -t cifs to a Windows share. The domain name that is sent to
the Windows machine is CIFS_LINUX_DOM even though in the smb.conf it is
different {and correct}. 

Version-Release number of selected component (if applicable):
2.6.18-1.2200.fc5

How reproducible:
Very

Steps to Reproduce:
1. yum -y update
2. kernel 2.6.17-1.2174_FC5 is removed
3. kernel 2.6.18-1.2200.fc5 is installed.
  
Actual results:
When mount -t cifs //server/share /mnt/name -o credentials=/etc/samba.auth.smb
returns:
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

Checking the event logs on the Windows server - the domain comes across as:
CIFS_LINUX_DOM instead of what is in smb.conf {which was working prior to the
update}. I googled that domain name and a link:
http://www.linuxhq.com/kernel/v2.6/18-rc4/fs/cifs/sess.c has several mentions of
that domain name. This happened around the 18th of Oct 2006 after an update and
reboot. I tried a before and after test on an FC5 box on vmware with no other
changes and the results were the same {Permission deined because of domain name}.

Expected results:
The mount should have been successful.

Additional info:
Comment 1 Dave Jones 2006-10-21 18:02:04 EDT

*** This bug has been marked as a duplicate of 211753 ***

Note You need to log in before you can comment on or make changes to this bug.