Bug 211789 - [PATCH] libipoddevice bump request
Summary: [PATCH] libipoddevice bump request
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libipoddevice   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Nielsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 213545 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-22 21:23 UTC by Simone Gotti
Modified: 2008-04-18 12:53 UTC (History)
2 users (show)

Fixed In Version: libipoddevice-0.5.3-4.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-18 12:53:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to the spec file. (795 bytes, patch)
2006-10-22 21:23 UTC, Simone Gotti
no flags Details | Diff
rpath removal patch (371 bytes, patch)
2006-11-11 19:39 UTC, Michel Alexandre Salim
no flags Details | Diff

Description Simone Gotti 2006-10-22 21:23:25 UTC
Description of problem:

New ipod models aren't recognized by libipoddevice-0.4.5-3.fc6 but compiling
latest libipoddevice-0.5.1 made it working. (for example the ipod cli command
and banshee recognizes it).


How reproducible:

always


Additional info:

the new version needs a new build require (sg3_utils-devel) and provides 2 more
files (an hal callout). 

A patch to the spec file is attacched.

Thanks!

Comment 1 Simone Gotti 2006-10-22 21:23:27 UTC
Created attachment 139089 [details]
A patch to the spec file.

Comment 2 Christopher Aillon 2006-10-23 15:42:35 UTC
And you're getting sg3_utils-devel from where?

Comment 3 Simone Gotti 2006-10-27 20:33:56 UTC
It's provided by Fedora Core (5 and 6).

In fedora core 3 and 4 there wasn't a devel package as there weren't provided
libraries (libipoddevice needs libsgutils.so.1 and so it won't build on these
releases).

Am I missing something?

Comment 4 Christopher Aillon 2006-11-01 23:11:15 UTC
*** Bug 213545 has been marked as a duplicate of this bug. ***

Comment 5 Christopher Aillon 2006-11-02 22:38:06 UTC
Just built this for devel.  Sorry, for some reason, I tried sg3-utils-devel
(note the dash instead of underscore).  Anyway, will be there shortly.

Comment 6 Michel Alexandre Salim 2006-11-11 19:09:54 UTC
Could you push the build to FC-5 and -6 as well? Or at least -6. Not being able
to use a lot of newer iPods with Banshee sounds like a big functionality loss to me.

Thanks.

Comment 7 Michel Alexandre Salim 2006-11-11 19:39:28 UTC
Created attachment 140970 [details]
rpath removal patch

The -devel spec file has a problem on x86_64 : the binaries contain /usr/lib64
as RPATH.

Comment 8 David Nielsen 2008-04-18 12:53:50 UTC
this seems fixed, we have libipoddevice-0.5.3-4.fc9.x86_64 in F9, F8 should have
a similar version


Note You need to log in before you can comment on or make changes to this bug.