Bug 211798 - bogus error message on nonexistent disk
bogus error message on nonexistent disk
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Glauber Costa
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-22 21:36 EDT by Tim Boyer
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 10:13:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Boyer 2006-10-22 21:36:34 EDT
Description of problem:

When specifying a file-based VBD that doesn't exist, e.g.:

disk = [ 'file:/var/filethatdoesntexist,hda1,rw' ]

the error message says

[root@buran xen]# xm create -c myxen
Using config file "myxen".
Error: Device 769 (vbd) could not be connected.
File /var/filethatdoesntexist is read-only, and so I will not
mount it read-write in a guest domain.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Glauber Costa 2006-10-23 15:45:12 EDT
I cannot reproduce the error, so, I hope it fixes it. 
rpms at:
http://people.redhat.com/riel/bz211798/

Please inform me if it really fixes it.
Comment 2 Glauber Costa 2006-10-27 09:07:09 EDT
Patch sent upstream.

Note You need to log in before you can comment on or make changes to this bug.