Bug 211833 - growisofs error 'unable to anonymously mmap'
growisofs error 'unable to anonymously mmap'
Status: CLOSED DUPLICATE of bug 189571
Product: Fedora
Classification: Fedora
Component: dvd+rw-tools (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-23 09:48 EDT by Tim Waugh
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 06:44:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2006-10-23 09:48:48 EDT
Description of problem:
When trying to write a DVD with growisofs I get an error.

Version-Release number of selected component (if applicable):
rw-tools-6.1-4.1

How reproducible:
100%

Steps to Reproduce:
1. growisofs -Z /dev/dvd -V backup -r .
  
Actual results:
[root@cyberelk backup-Lx7364]# du -sh .
1.9G    .
[root@cyberelk backup-Lx7364]# growisofs -Z /dev/dvd -V backup -r .
:-( unable to anonymously mmap 16777216: Resource temporarily unavailable

Additional info:
Worked fine in FC5.  Using the growisofs binary from FC5 works fine too.
Comment 1 Harald Hoyer 2006-10-23 10:46:51 EDT
Try:
$ ulimit -l unlimited          
Comment 2 Tim Waugh 2006-10-23 11:09:24 EDT
'ulimit -l unlimited' as root does work around the problem, yes (thanks!).  So
growisofs just needs to have a better fallback than just erroring out..
Comment 3 Harald Hoyer 2006-10-23 11:40:11 EDT
yep... will update
Comment 4 Travis Kirton 2006-10-26 03:33:10 EDT
Didn't work for me.  Have the same error message on mine as well.  Version from
FC5 works perfectly...version from FC6 gives me:

:-( unable to anonymously mmap 33554432:  Resource temporarily unavailable

ulimit -l unlimited doesn't work for me...still get the error above.
Comment 5 Bastien Nocera 2006-12-01 06:44:59 EST

*** This bug has been marked as a duplicate of 189571 ***
Comment 6 Martin 2007-03-09 12:04:08 EST
a solution for me was to increase the buffersize of growisofs with:
-use-the-force-luke=bufsize:16m

or in k3b under settings - configure k3b - Advanced
- Manual writing buffer size: 16MB

Note You need to log in before you can comment on or make changes to this bug.