This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 211837 - shadowman logos are outdated
shadowman logos are outdated
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: redhat-logos (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Brock Organ
: Desktop
Depends On:
Blocks: 212015
  Show dependency treegraph
 
Reported: 2006-10-23 10:15 EDT by Matthias Clasen
Modified: 2013-03-05 22:47 EST (History)
5 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:35:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Shadowman Start icons for RHEL...sizes include 16, 24, 32, 48, 96. (7.70 KB, application/zip)
2006-10-23 10:48 EDT, diana fong
no flags Details
shadowman icons that needs update (101.24 KB, application/octet-stream)
2006-10-24 13:10 EDT, David Zeuthen
no flags Details
Modified shadowmans from Comment 9's attachment (47.46 KB, application/zip)
2006-10-25 12:22 EDT, diana fong
no flags Details
Transparent Shadowmans in 16, 20, 22, 24, 32, 36, 48, 64, 96 (14.90 KB, application/zip)
2006-10-25 12:25 EDT, diana fong
no flags Details

  None (edit)
Description Matthias Clasen 2006-10-23 10:15:55 EDT
it uses the old start-here icon, rather than a shadowman.
Comment 1 RHEL Product and Program Management 2006-10-23 10:25:33 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 2 diana fong 2006-10-23 10:48:37 EDT
Created attachment 139135 [details]
Shadowman Start icons for RHEL...sizes include 16, 24, 32, 48, 96.
Comment 3 David Zeuthen 2006-10-23 10:53:37 EDT
dfong/mclasen: I believe older releases, e.g. RHEL4, uses a more cartoony hat as
shown here (picture randomly found on the Internet but ya'll probably remember)

 http://www.atmarkit.co.jp/flinux/prodreview/rhel4/g03.jpg

Are you sure we want to use the more flat Shadowman icon for RHEL5?
Comment 4 Matthias Clasen 2006-10-23 11:06:20 EDT
david, fyi: the panel is using the icon named "start-here" for the menu now
(which is why the old icon resurfaced)
Comment 5 David Zeuthen 2006-10-24 12:42:23 EDT
mclasen: so, why not simply fix the panel to use the an icon from redhat-logos
instead of, uhm, replacing the start-here icon with a Shadowman? Cuz, really,
I'm not how much sense it makes to make the icon named "start-here" a Shadowman,
in a way you're breaking at least some sort of ABI etc. etc.

FYI redhat-logos contains

 /usr/share/firstboot/pixmaps/shadowman-round-48.png
 /usr/share/pixmaps/redhat/shadowman-200.png
 /usr/share/pixmaps/redhat/shadowman-32.png
 /usr/share/pixmaps/redhat/shadowman-48.png
 /usr/share/pixmaps/redhat/shadowman-64.png
 /usr/share/pixmaps/redhat/shadowman-mini.png
 /usr/share/pixmaps/redhat/shadowman-round-48.png
 /usr/share/pixmaps/redhat/shadowman-transparent.png

which looks similar to the icons that Diana did though the red is somewhat more
vivid in her icons.
Comment 6 Matthias Clasen 2006-10-24 12:55:09 EDT
I'm fine with fixing this in the panel. The new icons are uptodate wrt to the
brand guidelines. Please replace the outdated existing ones.
Comment 7 David Zeuthen 2006-10-24 12:59:44 EDT
OK, reassigning this to redhat-logos and fixing up Summary to reflect that
shadowman icons in redhat-logos needs an update. New shadowman icons are
available in comment 2.

mclasen: Please open a new bug for the panel fix.
Comment 8 David Zeuthen 2006-10-24 13:00:41 EDT
Taking ownership of this bug (since johnp is no longer with us).
Comment 9 David Zeuthen 2006-10-24 13:10:30 EDT
Created attachment 139244 [details]
shadowman icons that needs update

dfong: We need updated icons for the ones in the attached archive file

These are

shadowman-200.png  shadowman-64.png	   shadowman-round-48.png
shadowman-32.png   shadowman-64.xpm	   shadowman-round-48.xpm
shadowman-32.xpm   shadowman-mini.png	   shadowman-round-mini.xpm
shadowman-48.png   shadowman-mini.xpm	   shadowman-transparent.png
shadowman-48.xpm   shadowman-round-32.xpm

Thanks.
Comment 10 David Zeuthen 2006-10-24 15:51:51 EDT
dfong: in addition we also need

shadowman-16.png
shadowman-20.png
shadowman-22.png
shadowman-36.png
shadowman-96.png

as redhat-artwork will symlink into these to provided themed icons for the gnome
panel menu.

Thanks. David.
Comment 11 David Zeuthen 2006-10-25 11:27:01 EDT
Actually as dfong pointed out this morning the existing shadowman
(shadownman-<size>.[png|xpm]]) are not transparent so they are not usable. So
the plan of attack is 

 1. Fixup existing icons in redhat-logos 
 2. Provide new icons shadowman-transparent-<size>.png where size=16, 20, 22,
32, 36, 48, 64, 96

then we get redhat-artwork to symlink into the shadowman-transparent-<size.png
icons.
Comment 12 David Zeuthen 2006-10-25 11:28:07 EDT
(further, we don't want to make the existing shadownman-<size>.[png|xpm] icons
transparent as that could break existing stuff)
Comment 13 Matthias Clasen 2006-10-25 11:32:37 EDT
Sounds good to me; although we should still update the existing non-transparent
shadowmen to the current approved version
Comment 14 David Zeuthen 2006-10-25 11:36:40 EDT
re comment 13, yea, that's what I meant with bullet 1. in comment 11
Comment 15 diana fong 2006-10-25 12:22:47 EDT
Created attachment 139364 [details]
Modified shadowmans from Comment 9's attachment
Comment 16 diana fong 2006-10-25 12:25:19 EDT
Created attachment 139365 [details]
Transparent Shadowmans in 16, 20, 22, 24, 32, 36, 48, 64, 96
Comment 18 David Zeuthen 2006-10-25 16:39:59 EDT
I verified these packages on Zack's x86 RHEL5 box and they looked good
Comment 20 Zack Cerza 2006-12-05 13:09:54 EST
What version of redhat-* is this fixed in? And which shadowman should be on the
panel menu?
Comment 21 David Zeuthen 2006-12-05 13:32:31 EST
Zack, see comment 9, comment 10 and comment 17. Thanks. 
Comment 22 Zack Cerza 2006-12-05 13:39:23 EST
Oh, now I see the package versions. Thanks.

But the PNGs mentioned in comment 10 are not present in either redhat-logos or
redhat-artwork. Is this a problem?

Either way, the shadowman I'm seeing on the panel is round with a white face,
and a transparent border. Sound right?
Comment 23 David Zeuthen 2006-12-05 13:49:33 EST
Sounds right. Mmm... perhaps rpmdiff can tell the files that changed? /me can't
seem to recall them at this point, sorry.
Comment 24 Zack Cerza 2006-12-05 17:06:42 EST
Well, redhat-artwork isn't symlinking to any shadoman-* files. Does this mean we
don't need the files in comment 10?
Comment 25 David Zeuthen 2006-12-07 16:24:20 EST
Mmmm.. I can't remember the specifics, sorry. 
Comment 26 RHEL Product and Program Management 2006-12-22 20:35:24 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.