Bug 2118379 - vdo kernel modules aren't available for the latest CentOS Stream 8 kernel, kernel-core-4.18.0-408.el8.x86_64
Summary: vdo kernel modules aren't available for the latest CentOS Stream 8 kernel, ke...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: kmod-kvdo
Version: CentOS Stream
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Susan LeGendre-McGhee
QA Contact: Filip Suba
URL:
Whiteboard:
: 2118884 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-08-15 16:10 UTC by Kris Knigga
Modified: 2022-08-18 19:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-16 17:29:28 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-131118 0 None None None 2022-08-15 16:13:42 UTC

Description Kris Knigga 2022-08-15 16:10:00 UTC
The most recent published kernel modules for vdo appear to be for the 4.18.0-373 kernel, and won't load on 4.18.0-408 due to symbol version issues.

$ uname -r
4.18.0-408.el8.x86_64

$ rpm -qil kmod-kvdo
Name : kmod-kvdo
Version : 6.2.6.14
Release : 84.el8
Architecture: x86_64
Install Date: Thu Aug 11 08:10:05 2022
Group : Unspecified
Size : 1733033
License : GPLv2+
Signature : RSA/SHA256, Thu Apr 7 10:25:42 2022, Key ID 05b555b38483c65d
Source RPM : kmod-kvdo-6.2.6.14-84.el8.src.rpm
Build Date : Thu Apr 7 10:02:18 2022
Build Host : x86-01.mbox.centos.org
Relocations : (not relocatable)
Packager : CentOS Buildsys <bugs>
Vendor : CentOS
URL : http://github.com/dm-vdo/kvdo
Summary : Kernel Modules for Virtual Data Optimizer
Description :
Virtual Data Optimizer (VDO) is a device mapper target that delivers
block-level deduplication, compression, and thin provisioning.

This package provides the kernel modules for VDO.
/etc/depmod.d/kvdo.conf
/lib/modules/4.18.0-373.el8.x86_64
/lib/modules/4.18.0-373.el8.x86_64/extra
/lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo
/lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo/uds
/lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo/uds/uds.ko
/lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo/vdo
/lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo/vdo/kvdo.ko
/usr/lib/.build-id
/usr/lib/.build-id/d4
/usr/lib/.build-id/d4/be5d85083e15dfe4febbb3bade63394b72e294
/usr/lib/.build-id/dd
/usr/lib/.build-id/dd/3520107c721f3e5c472f36168d46ca6accb2f5
/usr/share/doc/kmod-kvdo/greylist.txt

$ sudo insmod /lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo/vdo/kvdo.ko
insmod: ERROR: could not insert module /lib/modules/4.18.0-373.el8.x86_64/extra/kmod-kvdo/vdo/kvdo.ko: Invalid parameters

$ dmesg | tail
[174857.628302] kvdo: disagrees about version of symbol dm_set_target_max_io_len
[174857.628304] kvdo: Unknown symbol dm_set_target_max_io_len (err -22)
[174857.628412] kvdo: disagrees about version of symbol dm_register_target
[174857.628414] kvdo: Unknown symbol dm_register_target (err -22)
[174857.628489] kvdo: disagrees about version of symbol dm_table_get_mode
[174857.628491] kvdo: Unknown symbol dm_table_get_mode (err -22)
[174857.628533] kvdo: disagrees about version of symbol dm_table_get_md
[174857.628535] kvdo: Unknown symbol dm_table_get_md (err -22)
[174857.628597] kvdo: disagrees about version of symbol dm_get_device
[174857.628599] kvdo: Unknown symbol dm_get_device (err -22)

Comment 1 Susan LeGendre-McGhee 2022-08-15 19:47:06 UTC
Thank you for reaching out. The newest version of vdo for RHEL 8/CentOS 8 (version 6.2.7.17) is compatible with kernel 4.18.0-408.el8.x86_64. I recommend downloading and installing it from https://github.com/dm-vdo/kvdo/releases to correct this issue. Otherwise, I see in the CentOS 8 Stream GitLab that version 6.2.7.17 was imported two days ago. As such, I'd expect it to be available on the CentOS Stream 8 site soon.

Comment 2 Susan LeGendre-McGhee 2022-08-17 16:19:15 UTC
*** Bug 2118884 has been marked as a duplicate of this bug. ***

Comment 3 Kris Knigga 2022-08-18 19:38:23 UTC
(In reply to Susan LeGendre-McGhee from comment #1)
> Thank you for reaching out. The newest version of vdo for RHEL 8/CentOS 8
> (version 6.2.7.17) is compatible with kernel 4.18.0-408.el8.x86_64. I
> recommend downloading and installing it from
> https://github.com/dm-vdo/kvdo/releases to correct this issue. Otherwise, I
> see in the CentOS 8 Stream GitLab that version 6.2.7.17 was imported two
> days ago. As such, I'd expect it to be available on the CentOS Stream 8 site
> soon.

Thanks for the update.


Note You need to log in before you can comment on or make changes to this bug.