Bug 211980 - exception with empty route
exception with empty route
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-network (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
: 213354 216648 (view as bug list)
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-10-24 06:01 EDT by Bastien Nocera
Modified: 2009-06-19 05:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 14:23:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2006-10-24 06:01:20 EDT
Component: system-config-network
Version: 1.3.91
Summary: TB94e1a8fa sharedtcpip.py:176:route_update:TypeError: sequence item not
a string or unicode object

Traceback (most recent call last):
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py", line
284, in on_routeAddButton_clicked
    route_update(xml, device)
  File "/usr/share/system-config-network/netconfpkg/gui/sharedtcpip.py", line
176, in route_update
    clist.append([route.Address, route.Netmask, route.Gateway])
TypeError: sequence item not a string or unicode object

Local variables in innermost frame:
device: Device.AutoDNS=true
Device.HardwareAddress=00:0C:29:46:77:6A
Device.Type=Ethernet
Device.IPv6Init=false
Device.StaticRoutes.1.Gateway=[]
Device.StaticRoutes.1.Netmask=[]
Device.StaticRoutes.1.Address=[]
Device.Netmask=
Device.BootProto=dhcp
Device.Device=eth0
Device.OnBoot=true
Device.IP=
Device.OnParent=false
Device.DeviceId=eth0
Device.AllowUser=false
Device.Gateway=

xml: <gtk.glade.XML object (PyGladeXML) at 0xb79b58ec>
route: Route.Gateway=[]
Route.Netmask=[]
Route.Address=[]

clist: <gtk.CList object (GtkCList) at 0xb79b5fa4>


1. Launch system-config-network
2. Select an interface, click "Edit"
3. Select the route tab, then "Add..."
4. Click OK without filling in anything
5. Exception as above
Comment 2 RHEL Product and Program Management 2006-10-31 14:40:30 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 3 Harald Hoyer 2006-11-02 05:53:35 EST
*** Bug 213354 has been marked as a duplicate of this bug. ***
Comment 4 Harald Hoyer 2006-11-02 05:55:47 EST
not only with empty routes... see Bug #213354 
Comment 5 Harald Hoyer 2006-11-02 06:00:58 EST
nothing changed in the code since FC5.. so my first guess is gtk.clist
Comment 6 Harald Hoyer 2006-11-02 06:13:55 EST
ok.. found the bug.
Comment 7 Otto Rey 2006-11-02 08:56:17 EST
The same in Fedora Core 6, without empty routes. IMHO the Severity must be
Urgent or High.
Comment 8 Harald Hoyer 2006-11-06 11:46:54 EST
system-config-network-1.3.96-1
Comment 10 Harald Hoyer 2006-11-14 08:39:44 EST
fixed in system-config-network-1.3.96-1
Comment 12 Harald Hoyer 2006-11-29 10:28:59 EST
*** Bug 216648 has been marked as a duplicate of this bug. ***
Comment 13 Amit Bhutani 2006-11-29 18:50:14 EST
Can we get system-config-network-1.3.96-1 posted to a people page so we can
download, test and report results?

Latest we have in-house is Beta2 that has system-config-network-1.3.95-1.
Comment 14 Robert Hentosh 2006-12-06 11:49:51 EST
(In reply to comment #13)
> Can we get system-config-network-1.3.96-1 posted to a people page so we can
> download, test and report results?

Obtained a copy for Dell.

-- Robert
Comment 15 Amit Bhutani 2006-12-13 10:36:22 EST
Dell has verified fix as per comment #6 From Giribabu Bikki in bz216648. Pasting
the comment.

Comment #6 From Giribabu Bikki (giribabu_bikki@dell.com)  	 on 2006-12-07 02:28
EST  	[reply]  	   	 
I regressed with system-config-network-1.3.96-1 and it seems this bug has been fixed
Comment 16 John Feeney 2006-12-14 16:19:27 EST
Even though this has a MODIFIED status, Dell wants to make sure that this is
shipped in 5.0.0 and is fixed for their systems. Thus Dell wants it to be a
blocker for 5.0.0.
Comment 17 Pete Graner 2006-12-17 01:44:36 EST
Need QE ACK pls.
Comment 20 Giribabu Bikki 2006-12-20 07:51:58 EST
I regressed with  system-config-network-1.3.97-1.el5 which is shipped with
RHEL5-b2 snapshot-3 and this issue is fixed.
Comment 21 Amit Bhutani 2006-12-20 12:17:32 EST
Settin to VERIFIED based on comment #20. RH- Please close.

Note You need to log in before you can comment on or make changes to this bug.