Bug 21199 - setw ignored
setw ignored
Status: CLOSED DUPLICATE of bug 18861
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 15:18 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-21 15:18:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-21 15:18:37 EST
#include <iomanip>
#include <iostream>

int main ()

{
  cout << setw (9) << 1.0 << setw (9) << 2.0 << endl;
}

...outputs:
12

...instead of:
        1        2
Comment 1 Jakub Jelinek 2000-11-21 15:44:05 EST

*** This bug has been marked as a duplicate of 18861 ***

Note You need to log in before you can comment on or make changes to this bug.