Bug 212024 - Xen fails to install fully virtualized Windows 2003 guests because of CD-ROM timeout
Xen fails to install fully virtualized Windows 2003 guests because of CD-ROM ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On: 211385
Blocks: 197865
  Show dependency treegraph
 
Reported: 2006-10-24 13:42 EDT by Chris Lalancette
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 20:38:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the windows boot CD failing (8.06 KB, image/png)
2006-10-24 13:43 EDT, Chris Lalancette
no flags Details

  None (edit)
Description Chris Lalancette 2006-10-24 13:42:19 EDT
I failed to install a windows 2003 guest with using virtual machine manager.
The problem is that i haven't any chance to press a key to boot the guest from CD.

The disk image I am using was ever installed with windows XP, and its MBR has
been saved windows boot loader.
When I boot it from ISO, the windows installer will pause for a little while to
let me choose booting from CDROM or hard disk.
But Virutal Machine Manager takes a long time to bring up the qemu window, and I
haven't any chance to choose boot from CDROM.

The screenshot is attached.
Comment 1 Chris Lalancette 2006-10-24 13:43:40 EDT
Created attachment 139246 [details]
Screenshot of the windows boot CD failing
Comment 3 Valmir Passero 2006-11-05 12:24:42 EST
(In reply to comment #1)
> Created an attachment (id=139246) [edit]
> Screenshot of the windows boot CD failing
> 

hi, need help about VIRT-MANAGER
Intall Windows XP on Fedora Core 6.0
Comment 4 Valmir Passero 2006-11-05 12:26:48 EST
(In reply to comment #0)
> I failed to install a windows 2003 guest with using virtual machine manager.
> The problem is that i haven't any chance to press a key to boot the guest from CD.
> 
> The disk image I am using was ever installed with windows XP, and its MBR has
> been saved windows boot loader.
> When I boot it from ISO, the windows installer will pause for a little while to
> let me choose booting from CDROM or hard disk.
> But Virutal Machine Manager takes a long time to bring up the qemu window, and I
> haven't any chance to choose boot from CDROM.
> 
> The screenshot is attached.

HI, YOU KNOW HOW INSTALL ONE WINDOWS 
WITH VIRTUAL MACHINE MANAGER?
Where I can get an image in hhtp://?????????
PEOPLE HELP!!!!!!!!!!!
Comment 7 Jay Turner 2006-11-22 08:40:36 EST
QE ack for RHEL5.
Comment 8 Daniel Berrange 2006-11-22 08:46:55 EST
There are actually two core problems here:


1.  python-virtinst  has a hardcoded to time.sleep(2) immediately after creating
the guest domain, so execution will not return to virt-manager for at least 2
seconds after the guest is created

2.  User then has to manually open the console window, which adds another couple
  of seconds delay.

To fully resolve the problem we need to address both these issues. I'm treating
this ticket as covering the first problem.  The second problem is already
tracked in a separate bug 211385.

Comment 9 Stephen Tweedie 2006-11-22 10:27:33 EST
> The disk image I am using was ever installed with windows XP, and its MBR 
> has been saved windows boot loader.

Can I confirm for sure that this does *not* happen if you run it on a fresh disk
image, but only on an image that is already installed with Windows?  If so, then
there's an obvious workaround, and the severity is much lower.
Comment 13 Daniel Berrange 2006-12-01 12:36:29 EST
While we do have to sleep, we don't have to sleep for a fixed 2 second timeout.
This 2 seconds is too long in some cases, and too short in others.

We should sleep in a loop in 250 ms increments, for upto say 5 seconds so we get
prompt response when the guest does startup.
Comment 14 Jeremy Katz 2006-12-01 13:53:47 EST
A bit ugly and not necessarily guaranteed to resolve the problem fully... but
have a patch that should be functional if someone has a reproducer for the
problem case.
Comment 16 Chris Lalancette 2006-12-07 18:05:27 EST
Jeremy,
     I can forward the package or the patch to the reporting customer and have
them test it out.  Let me know where to find it.

Thanks,
Chris Lalancette
Comment 17 Jeremy Katz 2006-12-07 21:16:58 EST
Patch is at
http://hg.et.redhat.com/virt/applications/virtinst--devel/?cs=9e34ad1488a1

If you need me to throw together a package, I can but it should be pretty
trivial to install on top of a running system.
Comment 20 Jeremy Katz 2006-12-15 09:32:04 EST
Great, thanks -- will pull in with the pvfb changes 
Comment 23 RHEL Product and Program Management 2006-12-22 20:38:59 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.

Note You need to log in before you can comment on or make changes to this bug.