Bug 212036 - xchat's spell checking support doesn't work
xchat's spell checking support doesn't work
Product: Fedora
Classification: Fedora
Component: xchat (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Depends On:
  Show dependency treegraph
Reported: 2006-10-24 14:38 EDT by Nathan G. Grennan
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.8.2-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-02 14:32:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2006-10-24 14:38:59 EDT
Description of problem:
xchat's spell checking support doesn't work. The checkbox in preferences does
nothing. The package is obviously meant to include spell checking support.

I recompiled it with --enable-spell=gtkspell instead of --enable-spell=static.
Then spell checking worked just fine.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install xchat
2. run xchat
3. type something like asdf into the input box
Actual results:
No red underline

Expected results:
Red underline

Additional info:
Comment 1 Peter Zelezny 2006-10-25 07:14:52 EDT
You need to install enchant from extras to get spelling.
Comment 2 Nathan G. Grennan 2006-10-25 12:33:17 EDT
Yes, installing enchant from extras does work, but it shouldn't require a extras
package to get that functionality. There is a check box in the application, it
should work. Instead of mysteriously turning on when enchant is installed.

I would say the recompile is the way to go, but it always screws with the input
box size. Enchant is a better way. So either enchant needs to move in to core,
it needs to be compiled dynamically against gtkspell, or switch to libsexy and
move it to core.
Comment 3 lleoneye 2006-12-05 10:36:25 EST
If you install the gnome-xchat frontend then spellcheching starts to work too.
It keeps working if you remove gnome-xchat again too

Its a bug!
Comment 4 lleoneye 2006-12-05 11:28:05 EST
ok xchat is just missing dependencies for libsexy and enchant!
Comment 5 Kevin Kofler 2007-06-02 14:32:34 EDT
Actually just enchant, but it's not required, so it would be incorrect to put 
this in as a dependency.
Comment 6 Kevin Kofler 2007-07-19 06:17:28 EDT
For the record, the latest F7 and Rawhide versions now use the system version 
of libsexy for spell checking, which has a Requires: enchant, so this issue has 
been solved as a side effect.

Note You need to log in before you can comment on or make changes to this bug.