Bug 212046 - [RHEL 3 U8 CS] If locks exist when NFS service failover occurs, filesystem can be mounted on both nodes
[RHEL 3 U8 CS] If locks exist when NFS service failover occurs, filesystem ca...
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: clumanager (Show other bugs)
3
All Linux
high Severity high
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 15:19 EDT by Issue Tracker
Modified: 2009-04-16 15:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0041
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 15:46:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to resolve the problem. (412 bytes, patch)
2006-10-24 15:22 EDT, Josef Bacik
no flags Details | Diff
Updated (686 bytes, patch)
2006-11-02 13:33 EST, Lon Hohberger
no flags Details | Diff

  None (edit)
Comment 6 Josef Bacik 2006-10-24 15:22:24 EDT
Created attachment 139259 [details]
Patch to resolve the problem.

Lon found this while helping me out with this issue, we never check the return
value of unmounting the FS.  This patch will return failure if the umount
fails, and keep problems where the FS gets mounted on both nodes from
happening.
Comment 8 Lon Hohberger 2006-11-02 13:33:57 EST
Created attachment 140166 [details]
Updated
Comment 9 Lon Hohberger 2006-11-02 13:46:40 EST
RHEL 3 U8 Cluster Suite can leave NFS share mounted on both nodes if file locks
are in place during service failover.

How reproducible:
Intermittent 

Steps to reproduce:
1) Set up two node cluster with NFS export
2) On a client system, edit a file on the NFS share with Open Office
3) While the file is open on the client, use the cluster GUI on the server to
failover the NFS service to the second node
4) Watch open office crash and use df -h on both cluster nodes to observe the
NFS share mounted in both places

Expected results:
Either one of the following:
1) The failover does not success because the locks are in place and the
filesystem can not be unmounted
Comment 17 Red Hat Bugzilla 2007-01-29 15:46:25 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0041.html

Note You need to log in before you can comment on or make changes to this bug.