Bug 212062 - FC6 kernel locks up right away on setting of rodata to read only
FC6 kernel locks up right away on setting of rodata to read only
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
urgent Severity urgent
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 16:07 EDT by Steven Rostedt
Modified: 2015-01-04 17:29 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 01:03:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to check for RW changes of rodata instead of RO (632 bytes, patch)
2006-10-24 16:07 EDT, Steven Rostedt
no flags Details | Diff

  None (edit)
Description Steven Rostedt 2006-10-24 16:07:20 EDT
Description of problem:
Kernel hangs on start up due to execshield and readonly data.

Version-Release number of selected component (if applicable):
devel

How reproducible:
always

Steps to Reproduce:
1.boot kernel
2.locks up
3.
  
Actual results:
locks up

Expected results:
continues


Additional info:

The problem is that the code in change_page_attr checks to see if the ro
data section is being change to PAGE_KERNEL_RO.  I believe what should be
done is to check to see if this section is being set to RW.

Attached is a patch.
Comment 1 Steven Rostedt 2006-10-24 16:07:24 EDT
Created attachment 139266 [details]
patch to check for RW changes of rodata instead of RO
Comment 2 Dave Jones 2006-10-28 01:03:00 EDT
fixed in cvs

Note You need to log in before you can comment on or make changes to this bug.