Bug 212063 - error in postinstall scriptlet for xsane-gimp
error in postinstall scriptlet for xsane-gimp
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
: 212131 212442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 16:11 EDT by David Baron
Modified: 2008-03-07 10:31 EST (History)
2 users (show)

See Also:
Fixed In Version: f8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-07 10:31:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David Baron 2006-10-24 16:11:20 EDT
Description of problem:  In the xsane-gimp update pushed to FC5 updates today,
there's an error in the postinstall scriptlet:

# yum upgrade
...
  Updating  : autofs                       ####################### [ 4/20]
  Updating  : xsane-gimp                   ####################### [ 5/20]
/var/tmp/rpm-tmp.27650: line 1: [: missing `]'
  Updating  : mutt                         ####################### [ 6/20]
...


Version-Release number of selected component (if applicable):
xsane-gimp-0.991-3.fc5

How reproducible:
Didn't try.

Steps to Reproduce:
1. Upgrade to xsane-gimp-0.991-3.fc5 using yum
  
Actual results: error message (and perhaps something broken)

Expected results: no error message

Additional info:

The following:

$ rpm -q --scripts xsane-gimp
postinstall scriptlet (using /bin/sh):
if [ -x "/usr/sbin/gimp-plugin-mgr"]; then
    /usr/sbin/gimp-plugin-mgr --install xsane
fi
...

shows that there's a missing space between the " and the ].


It seems like this could be the result of the fix for bug 209648 based on
reading that bug (although I didn't look in CVS).
Comment 1 Michal Jaegermann 2006-10-24 19:16:16 EDT
xsane-gimp-0.991-3.fc6 for FC6 is affected in the same way
Comment 2 Nils Philippsen 2006-10-25 02:39:07 EDT
Argh. That'll teach me to bypass testing.

Supposedly fixed 0.991-4 is on the way.
Comment 3 Nils Philippsen 2006-10-25 06:54:41 EDT
*** Bug 212131 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2006-10-25 10:55:58 EDT
xsane-0.991-4.fc5 has been pushed for fc5, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Nils Philippsen 2006-10-27 03:21:54 EDT
*** Bug 212442 has been marked as a duplicate of this bug. ***
Comment 6 Jonathan Underwood 2008-03-07 10:14:39 EST
This bug can presumably be closed?
Comment 7 Nils Philippsen 2008-03-07 10:31:42 EST
Yes.

Note You need to log in before you can comment on or make changes to this bug.