Bug 212076 - Allow longer hostnames with rwhod / ruptime
Allow longer hostnames with rwhod / ruptime
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rwho (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Honza Horak
qe-baseos-daemons
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 17:10 EDT by William Yardley
Modified: 2013-04-12 14:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-25 03:00:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (2.10 KB, patch)
2007-08-10 07:48 EDT, Jiri Moskovcak
no flags Details | Diff
Proposed patch with updated man page (2.63 KB, patch)
2011-12-07 09:47 EST, Honza Horak
no flags Details | Diff

  None (edit)
Description William Yardley 2006-10-24 17:10:18 EDT
Description of problem:

rwho-0.17-18

How reproducible:

ruptime seems to truncate hostnames at 12 characters. There doesn't seem to be
an option to print longer hostnames. I'm not sure if this limitation is just in
the way ruptime prints the hostname, or if it's a limitation of rwhod or even
the protocol.

Would it be possible to allow longer hostnames? Even if you up it to 15 or 17
characters, output should easily fit in a 70 / 80 character wide terminal.
Comment 1 Jiri Moskovcak 2007-08-10 07:48:37 EDT
Created attachment 161045 [details]
Proposed patch

This patch allows you to use -n:<hostnamelen> to set desired output length for
hostname. The default value is still 12 chars.
Comment 2 RHEL Product and Program Management 2007-12-03 15:39:27 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 12 RHEL Product and Program Management 2012-06-11 21:11:10 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 15 RHEL Product and Program Management 2012-10-10 07:47:34 EDT
Thank you for submitting this issue for consideration. Red Hat Enterprise Linux 5 has reached the end of Production 1 Phase of its Life Cycle.  Red Hat does not plan to incorporate the suggested capability in a future Red Hat Enterprise Linux 5 minor release. If you would like Red  Hat to re-consider this feature request and the requested functionality is not currently in Red Hat Enterprise Linux 6, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.