Bug 212093 - wrong permissions on /usr/include/totem, /usr/include/totem/1
Summary: wrong permissions on /usr/include/totem, /usr/include/totem/1
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: totem   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-24 23:32 UTC by Ben Liblit
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.16.5-1.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-29 18:40:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Liblit 2006-10-24 23:32:57 UTC
Description of problem:


Version-Release number of selected component (if applicable):

totem-devel-2.16.1-1.fc6


How reproducible:

Consistently reproducible.


Steps to Reproduce:
1. remove the totem-devel rpm
2. manually remove /usr/include/totem and subdirectories
3. reinstall the totem-devel rpm
4. as non-root, compile any C program that uses totem headers

Actual results:

Compilation fails due to insufficient permissions on /usr/include/totem and
/usr/include/totem/1 directories.

Expected results:

Compilation should succeed.  Directories containing totem's headers should be
world readable and world executable.

Additional info:

totem-devel package does not claim to own /usr/include/totem or
/usr/include/totem/1 directories.  The directories are created at package
install time, but with permissions that do not allow access by non-root users. 
Incidentally, this will also cause the directories to be left behind, empty,
should totem-devel be uninstalled later.

Comment 1 Bastien Nocera 2006-10-27 09:27:51 UTC
Ben, is this still the case with FC6 release?

Comment 2 Ben Liblit 2006-10-29 02:46:37 UTC
Running "rpm -ql totem-devel" under FC6 shows that the totem-devel package still
does not claim to own /usr/include/totem or /usr/include/totem/1 directories. 
So yes, the problem still occurs with the official, final FC6 release.

Comment 3 Fedora Update System 2007-01-29 18:35:02 UTC
totem-2.16.5-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Comment 4 Fedora Update System 2007-02-12 17:28:44 UTC
totem-2.16.5-1.fc6 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.