Bug 212096 - ieee1394: Error parsing configrom for node 0-00:1023
ieee1394: Error parsing configrom for node 0-00:1023
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 20:26 EDT by John Reiser
Modified: 2007-12-30 21:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-30 21:45:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
lspci; lspci -n; lspsi -v -v (9.62 KB, text/plain)
2006-10-24 20:26 EDT, John Reiser
no flags Details
filenames in /sys containing "1394" (2.37 KB, text/plain)
2006-10-24 20:29 EDT, John Reiser
no flags Details

  None (edit)
Description John Reiser 2006-10-24 20:26:59 EDT
Description of problem: Strange message in /var/log/messages related to firewire
 interface and/or device.


Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
Always

Steps to Reproduce:
1. Attach ieee1394 external harddrive with 3 ext3 filesystems, then power it on.
2. Look in /var/log/messages.
3.
  
Actual results:
kernel: ieee1394: Error parsing configrom for node 0-00:1023
kernel: SCSI subsystem initialized
kernel: ieee1394: sbp2: Driver forced to serialize I/O (serialize_io=1)
kernel: ieee1394: sbp2: Try serialize_io=0 for better performance
kernel: scsi0 : SBP-2 IEEE-1394
kernel: ieee1394: sbp2: Logged into SBP-2 device
kernel:   Vendor: Initio    Model: ST3300831A        Rev: 4.07
kernel:   Type:   Direct-Access                      ANSI SCSI revision: 00
kernel: scsi 0:0:0:0: Attached scsi generic sg0 type 0
kernel: SCSI device sda: 586072368 512-byte hdwr sectors (300069 MB)
kernel: sda: Write Protect is off 
kernel: sda: got wrong page
kernel: sda: assuming drive cache: write through
kernel: SCSI device sda: 586072368 512-byte hdwr sectors (300069 MB)
kernel: sda: Write Protect is off 
kernel: sda: got wrong page
kernel: sda: assuming drive cache: write through
kernel:  sda: sda1 sda2 sda3
kernel: sd 0:0:0:0: Attached scsi disk sda


Expected results:
No complaints.

Additional info: will attach lspci output and names of files related to ieee1394
from /sys/class and /sys/bus and /sys/devices.
Comment 1 John Reiser 2006-10-24 20:26:59 EDT
Created attachment 139293 [details]
lspci; lspci -n; lspsi -v -v
Comment 2 John Reiser 2006-10-24 20:29:11 EDT
Created attachment 139295 [details]
filenames in /sys containing "1394"

find /sys/class /sys/bus /sys/devices  |  grep 1394
Comment 3 John Reiser 2006-10-24 22:33:02 EDT
Similar messages when unmount filesystems, unplug the harddrive, plug in an
external CD+DVD writer+reader, and turn it on:
kernel: ieee1394: Error parsing configrom for node 0-00:1023
kernel: ieee1394: Error parsing configrom for node 0-01:1023
kernel: ieee1394: Error parsing configrom for node 0-00:1023
kernel: scsi1 : SBP-2 IEEE-1394
kernel: ieee1394: sbp2: Logged into SBP-2 device
kernel:   Vendor: SONY      Model: DVD RW DRU-720A   Rev: JY02
kernel:   Type:   CD-ROM                             ANSI SCSI revision: 00
kernel: scsi 1:0:0:0: Attached scsi generic sg0 type 5
kernel: sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray

Inserting the FC6 i386 DVD into the external drive does not bring up nautilus,
even though inserting the same DVD into an internal drive /dev/hdc does open a
nautilus filesystem+directory window.
Comment 4 Stefan Richter 2006-11-17 04:30:16 EST
"Error parsing configrom for node 0-00:1023" is a normal condition if it occurs
only temporary, like in your case. The kernel driver cannot predict if the
condition will go away, therefore always logs the message whenever it has
difficulties to access a device's configuration ROM.

"sbp2: Driver forced to serialize I/O (serialize_io=1)" and "Try serialize_io=0
for better performance" is about a choice how the sbp2 driver can communicate
with a device. The default is safer; the faster alternative which can be
switched on by the serialize_io=0 module load parameter _may_ be slightly better
performing but has always been buggy. I'm slowly working on fixing all the
associated subtle bugs. However potential performance gains of the alternative
mode are often small to non-existent, therefore I recently removed both of these
log messages from the latest FireWire driver code which is pending for
submission to Linux 2.6.20.

"sda: got wrong page" + "sda: assuming drive cache: write through" is the result
of a firmware bug of Initio based SBP-2 devices. Linux' SCSI stack is able to
handle this since Linux 2.6.16 and 2.6.15.5.

Summary:
None of these messages indicate a problem whatsoever, at least in case of both
reporters. (If there was silence from the ieee1394 and SCSI drivers after "Error
parsing configrom" and the device wasn't accessible, then there would be a real
problem.)

"Fix":
 - I can't see how the "Error parsing configrom" message could be avoided for
transient non-fatal situations.
 - Those sbp2 messages are already removed in recent driver code.
 - The SCSI messages are sensible to print although they are hardly of value for
end users. If the Red Hat maintainers don't want this message to be displayed by
default, they could suggest to the upstream SCSI maintainers to suppress this
unless the SCSI logging level is raised or do this in a Red Hat specific patch.
Comment 5 Stefan Richter 2006-11-17 04:35:54 EST
PS: The fact that nautilus doesn't show the DVD is an unrelated problem. I can't
comment further on it without more diagnostics at which level the problem
occurs. Might be a userspace issue; hald or whatever. (I'm not a RHEL or FC
user, just an upstream kernel driver maintainer.)
Comment 6 Jon Stanley 2007-12-30 21:45:45 EST
Closing per comment #4 and comment #5.  If you feel this is not correct, please
retest against a current version of Fedora (Fedora 8 at current), and either
reopen this bug or file a new one against that version.

Note You need to log in before you can comment on or make changes to this bug.