Bug 212104 - Georgian text cannot be displayed normally when zoom out the page in Konqueror
Georgian text cannot be displayed normally when zoom out the page in Konqueror
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 23:35 EDT by Nicole Dai
Modified: 2008-01-23 07:47 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 07:46:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
with normal size Georgian text displayed normally (136.04 KB, image/png)
2006-10-24 23:35 EDT, Nicole Dai
no flags Details
After zoom out Georgian text displayed abnormally (102.09 KB, image/png)
2006-10-24 23:38 EDT, Nicole Dai
no flags Details
Georgian text displayed in Kate (115.93 KB, image/png)
2006-10-25 01:20 EDT, Nicole Dai
no flags Details
Georgian text at original zoom (115.88 KB, image/jpeg)
2008-01-23 07:46 EST, Lukáš Tinkl
no flags Details
Georgian text zoomed up (132.32 KB, image/jpeg)
2008-01-23 07:47 EST, Lukáš Tinkl
no flags Details

  None (edit)
Description Nicole Dai 2006-10-24 23:35:30 EDT
Description of problem:
Georgian text cannot be displayed normally when zoom out the page in Konqueror. 
Pls refer to attached screenshots for details.

Version-Release number of selected component (if applicable):
kdebase-3.5.4-12.fc6
RHEL5-Client-20061020.1

How reproducible:
Always

Steps to Reproduce:
1.Launch Konqueror.
2.Load http://www.unicode.org/iuc/iuc10/x-utf8.html.
3.Zoom out the page by Ctrl++.
  
Actual results:
After zoom out, Georgian text on the page displays as boxes.

Expected results:


Additional info:
Comment 1 Nicole Dai 2006-10-24 23:35:39 EDT
Created attachment 139299 [details]
with normal size Georgian text displayed normally
Comment 2 Nicole Dai 2006-10-24 23:38:49 EDT
Created attachment 139301 [details]
After zoom out Georgian text displayed abnormally
Comment 3 Nicole Dai 2006-10-25 01:20:41 EDT
Created attachment 139306 [details]
Georgian text displayed in Kate

The problem also was found when zoom out Georgian text in Kate. Seems the font
cannot be zoomed out.
Comment 4 Akira TAGOH 2006-10-25 10:51:15 EDT
It sounds like a font issue because of no outline font for Georgian though, Qt
may also need a feature to show the missing sized characters like Pango does?
Comment 5 Leon Ho 2006-11-28 05:01:00 EST
Look like it is not a bug for RHEL5 as it is either a lack of font problem or a
feature implementation. Can we clone it to fc devel instead?
Comment 6 Jens Petersen 2007-09-04 22:44:32 EDT
moving to Fedora for testing there
Comment 7 Lukáš Tinkl 2008-01-23 07:46:06 EST
The feature is definitely corrected here on F8, looks more like a problem with 
installed fonts (I think the user installed non-scalable fonts only). 
Comment 8 Lukáš Tinkl 2008-01-23 07:46:53 EST
Created attachment 292630 [details]
Georgian text at original zoom
Comment 9 Lukáš Tinkl 2008-01-23 07:47:27 EST
Created attachment 292631 [details]
Georgian text zoomed up

Note You need to log in before you can comment on or make changes to this bug.