Bug 212131 - broken postinstall scriptlet
broken postinstall scriptlet
Status: CLOSED DUPLICATE of bug 212063
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 04:54 EDT by Ralf Corsepius
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 06:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2006-10-25 04:54:07 EDT
Description of problem:
The postinstall scriptlet contains a syntax error:

# rpm -q -scripts xsane-gimp
postinstall scriptlet (using /bin/sh):
if [ -x "/usr/sbin/gimp-plugin-mgr"]; then
    /usr/sbin/gimp-plugin-mgr --install xsane
fi

Note, there is a blank missing between the '"' and the ']' on line containing
the 'if'.

This causes yum-updates to fail:
  Updating  : xsane-gimp                   ####################### [ 8/24]
/var/tmp/rpm-tmp.95854: line 1: [: missing `]'
...

Version-Release number of selected component (if applicable):
xsane-gimp-0.991-3.fc5

How reproducible:
Deterministic
Comment 1 Nils Philippsen 2006-10-25 06:54:37 EDT

*** This bug has been marked as a duplicate of 212063 ***

Note You need to log in before you can comment on or make changes to this bug.