Bug 21214 - architecture "aliases" are not used
architecture "aliases" are not used
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
Aaron Brown
:
: 21237 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 20:06 EST by Arenas Belon, Carlo Marcelo
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-23 02:32:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arenas Belon, Carlo Marcelo 2000-11-21 20:06:44 EST
even if running RedHat 7.0 on a i686 architecture, the RHN Update Agent
would only use the i386 versions of the packages

there is a :

<member>
<name>architecture</name>
<value><string>i686</string></value>
</member>

entry on /etc/sysconfig/rhn/systemid

but the glibc-2.2-5.i386.rpm would be installed instead of the
glibc-2.2-5.i686.rpm that is best suited for this "architecture"

to be fair, i am not sure if this is a bug on the up2date scripts or in the
way the up2date "metadata" is build from the available updates

hope i could be of more help
Comment 1 Preston Brown 2000-11-28 11:54:19 EST
Cristian:  are you sure you are doing architecture scoring right?
Comment 2 Preston Brown 2000-11-28 14:52:05 EST
*** Bug 21237 has been marked as a duplicate of this bug. ***
Comment 3 Preston Brown 2000-11-28 15:05:25 EST
*** Bug 21237 has been marked as a duplicate of this bug. ***
Comment 4 Arenas Belon, Carlo Marcelo 2000-12-18 20:48:03 EST
FWIW latest glibc (2.2-9) errata is not "correctly" updated with the up2date
agent.

the "correct" rpm can be installed using :

  rpm -Uvh --force glibc-2.2-9-${ARCH}.rpm (where ARCH={i586,i686}

as a workaround
Comment 5 Arenas Belon, Carlo Marcelo 2000-12-23 02:32:16 EST
no more workaround AFAIK, latest up2date update (2.1.7-1) selected the right
glibc architecture (i686) on a i686 system
Comment 6 Arenas Belon, Carlo Marcelo 2000-12-23 02:36:19 EST
even if not on the "Bug IDs fixed" on :

  http://www.redhat.com/support/errata/RHBA-2000-138.html

this is already fixed

Note You need to log in before you can comment on or make changes to this bug.