Bug 212207 - grub configuration incorrect after clean install on Dell Optiplex GX270 with usb thumbdrive
grub configuration incorrect after clean install on Dell Optiplex GX270 with ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 13:12 EDT by Alastair Neil
Modified: 2008-04-04 00:21 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 00:21:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alastair Neil 2006-10-25 13:12:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20061011 Fedora/1.5.0.7-7.fc6 Firefox/1.5.0.7

Description of problem:
Clean install on a dell Optiplex GX270 with one samsung 70Gbyte IDE drive.
Booted from a Sony usb 2.0 Thumbdrive

device map shows
(hd0) /dev/sda

grub.conf

root and splashimage files relative to (hd1,0)
e.g:
splashimage=(hd1,0)/grub/splash.xpm.gz



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Steps to Reproduce:
1.boot from sony usb thumbdrive and install FC6
2.
3.

Actual Results:
grub configuration incorrect

Expected Results:
grub configuration correct

device map:
(hd0) /dev/hda

grub.conf files relative to (hd0,0)


Additional info:
Comment 1 Alastair Neil 2006-10-25 13:13:40 EDT
usb thumb drive was attached via a usb hub in my monitor
Comment 2 Harald Jensås 2006-10-30 06:50:43 EST
I had the exact same problem whe installing on my Dell Dimension 8300 using a 
Dell USB 64-MB memory key.

I solved it by manually editing the grub.conf file after booting into rescue 
mode using the USB key.
Comment 3 Brian McMinn 2006-11-17 00:35:57 EST
I think this might be a symptom of a bigger problem with how
the install code selects where to put the GRUB image.

I installed core 6 on a box with an internal hard drive but no
optical drive.  I booted from a USB flash drive (via diskboot.img)
and put the install ISO's on a USB hard drive.

During the install, I was given the option of installing GRUB on
the USB flash drive (/dev/sdb).  I couldn't find any way to tell
the install script that GRUB should really go on the internal hard
drive instead.  Yes, I know this is fairly easy to fix after the
install is done but I shouldn't have to do that.

Note that at the start of the install, I specifically told the 
install script that the two /dev/sd* devices were NOT to be used
for any of the install and that ALL of the installation was to
go onto /dev/hda.  Thus even the question of whether to put GRUB 
onto one of the USB devices was contrary to something I had already
specified in the install sequence.

To me this is a wart rather than a real error but it's still something
that I didn't expect.
Comment 4 David Wragg 2006-11-21 12:11:50 EST
Same issue for me.  Installing to a Lenovo Thinkpad T60 from a USB hard drive. 
The laptop SATA drive is sda, the USB drive is sdb.  I asked for an install to
sda only.  But I still get prompted to partition sdb, and then it wants to put
grub there.

I have no wish to have the grub bootloader written to this USB drive
thankyouverymuch, so this is a real bug for me.
Comment 5 Damien Covey 2007-04-10 19:06:52 EDT
I am having the same issue with fedora 6.92 on a Samsung R50.  My USB thumb
drive is /dev/sdb and internal hard drive /sda.  Anaconda prompts to install
grub on sdb and there is no option to install on sda.
Comment 6 Nicholas Miell 2007-06-01 15:34:22 EDT
Similar issue for me with the final F7 release, but no USB storage devices are
involved and it was an upgrade from FC6, not a fresh install.

I have a single IDE (PATA) drive and a single SATA drive. Anaconda loaded
sata_via and then pata_via, making the SATA drive sda and the PATA drive sdb and
proceeded to generate a grub.conf using (hd1) for sdb instead of the correct (hd0).

Looking at the EDD information, it appears that there's enough data supplied by
my BIOS to disambiguate the devices and determine relative ordering, so, uh,
maybe you should use that :)
Comment 7 Bug Zapper 2008-04-04 00:06:32 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.