Bug 212219 - LC_MESSAGES not set correctly for or_IN
LC_MESSAGES not set correctly for or_IN
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: 211936 212438
  Show dependency treegraph
 
Reported: 2006-10-25 14:19 EDT by Chris Lumens
Modified: 2014-03-16 23:03 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-06 15:13:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Lumens 2006-10-25 14:19:40 EDT
When testing bug 211936 under the or_IN locale, I noticed that the init script
messages were all showing up as white boxes.  This is because of the following
block in /etc/init.d/functions:

        case "${LANG:-}" in
                ja_JP*|ko_KR*|zh_CN*|zh_TW*|bn_*|bd_*|pa_*|hi_*|ta_*|gu_*)
                        export LC_MESSAGES=en_US

Perhaps it might be better to test *_IN* for all these Indic languages we are
adding?
Comment 1 Bill Nottingham 2006-10-25 15:22:58 EDT
Hm, that should probably just be taken out entirely.
Comment 4 Fedora Update System 2006-10-30 22:14:14 EST
initscripts-8.45.4-1 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.
Comment 5 Fedora Update System 2006-11-06 14:55:06 EST
initscripts-8.45.5-1 has been pushed for fc6, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.