Bug 212229 - RFE: different packages on the same repo
RFE: different packages on the same repo
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 15:00 EDT by Chitlesh GOORAH
Modified: 2014-01-21 17:55 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:37:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chitlesh GOORAH 2006-10-25 15:00:08 EDT
Description of problem:
Let's say a mirror A has the following problem:
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/testing/6/i386/xorg-x11-drv-nvidia-1.0.9626-2.lvn6.i386.rpm:
[Errno 14] HTTP Error 404: Date: Wed, 25 Oct 2006 18:40:49 GMT
Server: Apache/2.0.52 (Red Hat)
Content-Length: 412
Content-Type: text/html; charset=iso-8859-1

Let's say that I'm updating 3 packages.

What yum does is it downloads the header of packageONE from mirror A, it sees
that it's broken. Then looks for mirrorB, to continue.

Then for package TWO, yum seeks for that package from mirror A, which it finds
broken. Then it tries Mirror B.

It would be nice to have yum automatically updates its pointer to mirror B,
rather looking each time for packages in mirror A. It wastes time. People find
yum slow afterwards. 

Version-Release number of selected component (if applicable):
yum-3.0-6

How reproducible:
Everytime

Actual results:
---> Downloading header for xorg-x11-drv-nvidia to pack into transaction set.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/testing/6/i386/xorg-x11-drv-nvidia-1.0.9626-2.lvn6.i386.rpm:
[Errno 14] HTTP Error 404: Date: Wed, 25 Oct 2006 18:40:49 GMT
Server: Apache/2.0.52 (Red Hat)
Content-Length: 412
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/testing/6/i386/xorg-x11-drv-nvidia-1.0.9626-2.lvn6.i386.rpm:
[Errno 14] HTTP Error 404: Date: Wed, 25 Oct 2006 18:41:02 GMT
Server: Apache/2.2.3 (Fedora)
Vary: accept-language,accept-charset
Accept-Ranges: bytes
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1
Content-Language: en

Trying other mirror.
xorg-x11-drv-nvidia-1.0.9 100% |=========================|  32 kB    00:01
---> Package xorg-x11-drv-nvidia.i386 0:1.0.9626-2.lvn6 set to be updated
---> Downloading header for vnc-server to pack into transaction set.
vnc-server-4.1.2-5.fc6.i3 100% |=========================|  17 kB    00:02
---> Package vnc-server.i386 0:4.1.2-5.fc6 set to be updated
---> Downloading header for gstreamer-plugins-ugly to pack into transaction set.
http://wftp.tu-chemnitz.de/pub/linux/livna/fedora/6/i386/gstreamer-plugins-ugly-0.10.4-2.lvn6.i386.rpm:
[Errno 14] HTTP Error 404: Date: Wed, 25 Oct 2006 18:41:17 GMT
Server: Apache/2.0.52 (Red Hat)
Content-Length: 405
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
http://ftp-stud.fht-esslingen.de/pub/Mirrors/rpm.livna.org/fedora/6/i386/gstreamer-plugins-ugly-0.10.4-2.lvn6.i386.rpm:
[Errno 14] HTTP Error 404: Date: Wed, 25 Oct 2006 18:41:22 GMT
Server: Apache/2.2.3 (Fedora)
Vary: accept-language,accept-charset
Accept-Ranges: bytes
Connection: close
Transfer-Encoding: chunked
Content-Type: text/html; charset=iso-8859-1
Content-Language: en

Trying other mirror.
gstreamer-plugins-ugly-0. 100% |=========================|  17 kB    00:01
---> Package gstreamer-plugins-ugly.i386 0:0.10.4-2.lvn6 set to be updated
---> Downloading header for shadow-utils to pack into transaction set.
shadow-utils-4.0.17-7.fc6 100% |=========================|  49 kB    00:01
---> Package shadow-utils.i386 2:4.0.17-7.fc6 set to be updated
--> Running transaction check

Dependencies Resolved                                                          
                                             

Expected results:


Additional info:
Comment 1 Seth Vidal 2006-10-25 15:06:41 EDT
yum is actually doing the right thing. The problem right now is that there are
duplicate mirror entries in the mirrorlist you're getting back.
Comment 2 Chitlesh GOORAH 2006-10-25 15:14:01 EDT
what do you mean "doing the right thing" ?

how/when will duplicate mirror entries be fixed ?
Comment 3 Seth Vidal 2006-10-25 15:53:46 EDT
I mean yum sees each entry in the mirrorlist as a separate mirror. So trying it
out is the right thing.

the dupes should get fixed 'soon' I've passed it on to Mike who has been working
on the mirrorlist cgi.
Comment 4 Jeremy Katz 2007-04-25 14:37:40 EDT
This should be fixed now

Note You need to log in before you can comment on or make changes to this bug.