Bug 212243 - Cannot run acrobat reader under FC6
Cannot run acrobat reader under FC6
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gtk2 (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 15:43 EDT by Emmanuel Druon
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 16:00:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
diff file to correct the problem (214 bytes, patch)
2006-10-25 15:43 EDT, Emmanuel Druon
no flags Details | Diff
the patch that fix acroread (412 bytes, patch)
2006-10-28 00:49 EDT, Sergio Monteiro Basto
no flags Details | Diff
correction, sorry last patch can be apply clean (416 bytes, patch)
2006-11-02 20:28 EST, Sergio Monteiro Basto
no flags Details | Diff
other patch (1.33 KB, patch)
2006-11-03 08:44 EST, Sergio Monteiro Basto
no flags Details | Diff

  None (edit)
Description Emmanuel Druon 2006-10-25 15:43:18 EDT
Description of problem:
Can't run acroread (AdobeReader_enu-7.0.8-1.i386.rpm) - get expr: syntax error
message

Version-Release number of selected component (if applicable):
AdobeReader_enu-7.0.8-1.i386.rpm

How reproducible:
Everytime

Steps to Reproduce:
1. Install AdobeReader_enu-7.0.8-1.i386.rpm
2. try to run acroread
3.
  
Actual results:
expr: syntax error

Expected results:
acrobat reader starts

Additional info:
There's a problem in the way acrobat ready reads the version number of the gtk
library 
Bug corrected - see diff file
Comment 1 Emmanuel Druon 2006-10-25 15:43:19 EDT
Created attachment 139395 [details]
diff file to correct the problem
Comment 2 Sergio Monteiro Basto 2006-10-27 09:59:26 EDT
(In reply to comment #1)
> Created an attachment (id=139395) [edit]
> diff file to correct the 
> 
your diff don't have any difference 
Comment 3 Emmanuel Druon 2006-10-27 11:04:09 EDT
yes there is ! There is a * after one of the ] in the new version (at that's
what's missing) lol
Comment 4 Sergio Monteiro Basto 2006-10-27 12:12:56 EDT
ah! the patch is inverted, ok , works for me thanks !
Comment 5 Sergio Monteiro Basto 2006-10-28 00:49:25 EDT
Created attachment 139626 [details]
the patch that fix acroread
Comment 6 Sergio Monteiro Basto 2006-11-02 20:28:43 EST
Created attachment 140204 [details]
correction, sorry last patch can be apply clean
Comment 7 Sergio Monteiro Basto 2006-11-03 08:44:40 EST
Created attachment 140243 [details]
other patch 

from 
http://remi.collet.free.fr/index.php?2006/10/28/229-acrobat-reader-708-et-fedora-core-6

other patch , as root:
cd
wget http://remi.collet.free.fr/files/acroread.patch
cd /usr/local/Adobe/Acrobat7.0/bin
patch -b < ~/acroread.patch

Note You need to log in before you can comment on or make changes to this bug.