Bug 212254 - dmraid crashes on FC6 Final Release Installation
dmraid crashes on FC6 Final Release Installation
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dmraid (Show other bugs)
6
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Heinz Mauelshagen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 16:41 EDT by Mike Piscopo
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-17 12:21:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Piscopo 2006-10-25 16:41:42 EDT
Description of problem:


Version-Release number of selected component (if applicable): FC6-Final


How reproducible: Consistent


Steps to Reproduce:
1. Install on Shuttle XPC Athlon64 Dual Core with NVIDIA nForce 570 on-board
RAID Chipset, clean fresh system
2. Immediately after keyboard layout screen exception occurs
  
Actual results:

Traceback (most recent call first):
File "/usr/lib64/python2.4/site-packages/block/__init__.py", line 18, in dm_log
raise Exception, message
File "/usr/lib64/python2.4/site-packages/block/device.py", line 672, in get_map
self._RaidSet__map = _dm.map(name=self.name, table=self.rs.dmTable)
File "/usr/lib64/python2.4/site-packages/block/__init__.py", line 765, in
activate self.map.dev.mknod(self.prefix+self.name)
File "/usr/lib/anaconda/dmraid.py", line 168, in startAllRaid
rs.activate(mknod=True)
File "/usr/lib/anaconda/partedUtils.py", line 609, in startDmRaid dmList =
dmraid.startAllRaid(driveList)
File "/usr/lib/anaconda/partedUtils.py", line 968, in openDevices self.startDmRaid()
File "/usr/lib/anaconda/upgrade.py", line 91, in findExistingRoots
anaconda.id.diskset.openDevices()
File "/usr/lib/anaconda/upgrade.py", line 68, in findRootParts
anaconda.id.rootParts = findExistingRoots(anaconda)
File "/usr/lib/anaconda/dispatch.py", line 199, in moveStep rc =
stepFunc(self.anaconda)
File "/usr/lib/anaconda/dispatch.py", line 122, in gotoNext self.moveStep()
File "/usr/lib/anaconda/gui.py", line 923, in nextCliecked
self.anaconda.dispatch.gotoNext()
Exception: device-mapper: reload ioctl failed: Invalid argument

Local variables in innermost frame:
message: device-mapper: reload ioctl failed: Invalid argument
line: 1574
file: ioctl/libdm-iface.c
level: 3

Expected results:


Additional info:
Comment 1 Heinz Mauelshagen 2006-10-26 14:07:50 EDT
Looks like an anaconda flaw.
To make that sure, can you run dmraid on that machine directly (eg, from the
recovery CD) and attach the output of "dmraid -b;dmraid -r;dmraid -s;dmraid
-tay;dmraid -n" ?
Comment 2 Heinz Mauelshagen 2007-04-17 12:21:42 EDT
No response.
Closing.

Note You need to log in before you can comment on or make changes to this bug.