Bug 212278 - gaim uninstallable on x86_64
gaim uninstallable on x86_64
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 19:50 EDT by Kevin Otte
Modified: 2007-11-16 20:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 12:40:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Otte 2006-10-25 19:50:50 EDT
Description of problem:
gaim fails a dependency check when trying to install it on 64 bit.

Version-Release number of selected component (if applicable):
gaim 1.5.0 12.el4 x86_64

How reproducible:
up2date gaim

Steps to Reproduce:
1. Install RHEL 4 WS x86_64 minimal install
2. Register machine to satellite
3. up2date gaim
  
Actual results:
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
gaim  1.5.0-12.el4                       requires libnspr4.so()(64bit)
gaim  1.5.0-12.el4                       requires libnss3.so()(64bit)
gaim  1.5.0-12.el4                       requires libnss3.so(NSS_3.2)(64bit)
gaim  1.5.0-12.el4                       requires libnss3.so(NSS_3.3)(64bit)
gaim  1.5.0-12.el4                       requires libplc4.so()(64bit)
gaim  1.5.0-12.el4                       requires libplds4.so()(64bit)
gaim  1.5.0-12.el4                       requires libsmime3.so()(64bit)
gaim  1.5.0-12.el4                       requires libsoftokn3.so()(64bit)
gaim  1.5.0-12.el4                       requires libssl3.so()(64bit)
gaim  1.5.0-12.el4                       requires libssl3.so(NSS_3.2)(64bit)


Expected results:
up2date would find the appropriate packages to fulfill the dependencies and
install them.

Additional info:
Machine registered to UNC satellite.
Comment 1 Warren Togami 2006-10-25 20:51:32 EDT
I suspect something is wrong with up2date here.  Reassigning.
Comment 2 Kevin Otte 2006-11-01 16:04:44 EST
I tend to agree.  If I manually invoke rpm against the package in the cache, it
rightly suggests the appropriate packages:

# rpm -Uvh /var/spool/up2date/gaim-1.5.0-12.el4.x86_64.rpm
error: Failed dependencies:
        libao.so.2()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libnspr4.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libnss3.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libnss3.so(NSS_3.2)(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libnss3.so(NSS_3.3)(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libplc4.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libplds4.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libsilc-1.0.so.2()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libsilcclient-1.0.so.2()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libsmime3.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libsoftokn3.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libssl3.so()(64bit) is needed by gaim-1.5.0-12.el4.x86_64
        libssl3.so(NSS_3.2)(64bit) is needed by gaim-1.5.0-12.el4.x86_64
    Suggested resolutions:
        libao-0.8.5-2.EL.0.x86_64.rpm
        libsilc-0.9.12-7.x86_64.rpm
        seamonkey-nspr-1.0.3-0.el4.1.x86_64.rpm
        seamonkey-nss-1.0.3-0.el4.1.x86_64.rpm
Comment 3 Warren Togami 2007-07-27 13:14:44 EDT
What about now with the pidgin replacement of gaim?
Comment 4 Pradeep Kilambi 2007-07-27 18:01:55 EDT
pidgin indeed works fine and correctly satisfies dependencies by grabbing
required packages. up2date is working correctly as far as resolving
dependencies. If up2date cannot find dependency packages  in the channels it
would try and fail. In which case this is not an up2date issue, its a release
eng issue where dependencies are not populated in the channels. This is not a
bug for up2date component.

# cat /etc/redhat-release 
Red Hat Enterprise Linux AS release 4 (Nahant Update 5)

$ uname -i
x86_64

$ up2date pidgin

Fetching Obsoletes list for channel: rhel-x86_64-as-4...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
pidgin                                  1.5.1          1.el4             x86_64


Testing package set / solving RPM inter-dependencies...
########################################
pidgin-1.5.1-1.el4.x86_64.r ########################## Done.                   
gtkspell-2.0.7-2.x86_64.rpm ########################## Done.                   
libao-0.8.5-2.EL.0.x86_64.r ########################## Done.                   
libsilc-0.9.12-7.x86_64.rpm ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:libsilc                ########################################### [100%]
   2:libao                  ########################################### [100%]
   3:gtkspell               ########################################### [100%]
   4:pidgin                 ########################################### [100%]
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
gtkspell                                2.0.7          2                   
libao                                   0.8.5          2.EL.0              
libsilc                                 0.9.12         7                   

# 
Comment 5 Dennis Gregorovic 2007-08-23 13:26:02 EDT
Is this no longer an issue then?
Comment 6 Pradeep Kilambi 2007-08-29 11:42:37 EDT
Waiting on customer to confirm before closing as not an up2date issue. 
Comment 7 Kevin Otte 2007-08-29 12:30:51 EDT
In the intervening time I have upgraded my workstation to RHEL 5, so I no longer
have the ability to test this.
Comment 8 Pradeep Kilambi 2007-08-29 12:40:57 EDT
Thanks for the Info, Kevin! From our tests this seems to be working from
up2dates end. Was just waiting for your input. I guess I'll go ahead and close
this. If anyone has any other issues on this, feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.