Bug 212307 - ctorrent segfault when it starts
Summary: ctorrent segfault when it starts
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ctorrent (Show other bugs)
(Show other bugs)
Version: 5
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Dominik 'Rathann' Mierzejewski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-26 06:15 UTC by Don Russell
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 1.3.4-2.dnh2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 17:23:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Don Russell 2006-10-26 06:15:15 UTC
Description of problem:
ctorrent segfaults shortly after starting 

Version-Release number of selected component (if applicable):
1.3.4


How reproducible:
Always


Steps to Reproduce:
1. wget http://torrent.fedoraproject.org/torrents/Zod-dvd-i386.torrent
2. ctorrent -p 6881 Zod-dvd-i386.torrent
3.
  
Actual results:
Zod-dvd-i386 directory is created, the two files are created, the ctorrent segfaults


Expected results:
I expected the torrent download to run to completion


Additional info:

Comment 1 Dominik 'Rathann' Mierzejewski 2006-11-01 17:05:47 UTC
More precisely, it segfaults on i686 and sends bad data on x86_64 due to integer
overflow.

Comment 2 Dominik 'Rathann' Mierzejewski 2006-11-01 17:23:02 UTC
Updated package to Enhanced CTorrent which contains a fix for this, as CTorrent
seems to be unmaintained now.

Comment 3 Don Russell 2006-11-01 22:51:08 UTC
Thanks... now, if I could just get my /etc/yum.repos.d repo file fixed, I'd be
on the road again... :-(


Note You need to log in before you can comment on or make changes to this bug.